1602 résultats trouvés

par OOoiste
24 mars 2020, 21:10
Forum : Excel - VBA
Sujet : Dénombrement en ligne
Réponses : 14
Vues : 137

Re: Dénombrement en ligne

Bonsoir Juste pour dire que c'est possible par formule, même si c'est plus simple avec la macro. Il s'agit d'une formule matricielle, donc à valider par CTRL+MAJ+Entrée : =SI($A2=B$1;"";SOMME(FREQUENCE(SI(base!$A$1:$E$24=$A2;LIGNE(base!$A$1:$E$24));LIGNE(base!$A$1:$A$24))*FREQUENCE(SI(base!$A$1:$E$2...
par OOoiste
20 mars 2020, 21:21
Forum : Excel - VBA
Sujet : Répartition chiffre d'affaires par jour
Réponses : 8
Vues : 91

Re: Répartition chiffre d'affaires par jour

Bonsoir,

Pour l'écart, voir cellule D2.

A+
par OOoiste
19 mars 2020, 21:29
Forum : Excel - VBA
Sujet : Lister/ trier des combinaisons
Réponses : 3
Vues : 43

Re: Lister/ trier des combinaisons

Bonsoir,

Avec la nouvelle fonction FILTRE (excel 365) :
=FILTRE($A$2:$A$6;INDEX($B$2:$F$6;0;EQUIV($C$9;$B$1:$F$1;0))=COLONNES($B$11:B11))
A+
par OOoiste
18 mars 2020, 17:34
Forum : Excel - VBA
Sujet : Fonction FILTRE et validation de données
Réponses : 1
Vues : 44

Re: Fonction FILTRE et validation de données

Bonjour,

Bien que non validée matriciellement, il s'agit d'une fonction matricielle.
Et il n'est pas possible d'utiliser une formule matricielle comme validation de données dans Excel (à contrario de LibreOffice Calc).

A+
par OOoiste
6 janvier 2020, 17:08
Forum : Excel - VBA
Sujet : Faire correspondre des données dans excel
Réponses : 2
Vues : 47

Re: Faire correspondre des données dans excel

Bonjour,

Le problème vient du fait que les codes dans le rapport sont des valeurs numériques alors qu'elles sont en "texte" dans la base.

Pour contourner le problème il suffit de concaténer le nombre avec une chaine de texte nulle .
G2 → G2&""
=RECHERCHEV(G2&"";Données!$A$2:$B$67;2;FAUX)
A+
par OOoiste
6 janvier 2020, 10:32
Forum : Excel - VBA
Sujet : Format fraction dénominateur figé même si résultat > 1
Réponses : 3
Vues : 51

Re: Format fraction dénominateur figé même si résultat > 1

Bonjou J'ai sélectionné le format personnalisé #" "??/9 ... Auriez-vous s'il vous plait une solution pour que même au-delà de 1, Excel ne scinde pas en Nombre entier + fraction / 9 mais bien toujours en fraction / 9 uniquement ? Ton format personnalisé #" "??/9 signifie "nombre entier" (#), puis "es...
par OOoiste
4 janvier 2020, 20:39
Forum : Excel - VBA
Sujet : NB.SI 3 demandes
Réponses : 4
Vues : 71

Re: NB.SI 3 demandes

Bonsoir,
tulipe_4 a écrit :
4 janvier 2020, 15:37
bonjour
=SOMMEPROD(--(NB.SI(G10:Ak10;{"A"."T"."C"})))
cordialement
NB.SI renvoie un nombre (ou une matrice de nombres ici), les -- sont donc superflus.

A+
par OOoiste
4 janvier 2020, 20:36
Forum : Excel - VBA
Sujet : Question sur la fonction CHERCHE
Réponses : 3
Vues : 68

Re: Question sur la fonction CHERCHE

Bonsoir,

Vérifies que dans les cellules qui contiennent le terme cherché, il n'y a pas d'espaces à la fin.

A+
par OOoiste
12 décembre 2019, 13:39
Forum : Excel - VBA
Sujet : Plusieurs si alors calculer valeurs
Réponses : 3
Vues : 72

Re: Plusieurs si alors calculer valeurs

Bonjour,
=MEDIANE(0;8;A1-40)
A+