347 résultats trouvés

par Zebulon2
Hier, 16:16
Forum : Excel - VBA
Sujet : Transposer Lignes Colonnes
Réponses : 8
Vues : 52

Re: Transposer Lignes Colonnes

Bonjour à tous,

Une autre contribution, sans VBA.
Cordialement.
dani0388.xlsx
(20.29 Kio) Téléchargé 5 fois
par Zebulon2
5 avril 2020, 17:34
Forum : Excel - VBA
Sujet : Tableau d'une feuille a l'autre
Réponses : 11
Vues : 142

Re: Tableau d'une feuille a l'autre

Bonsoir,

Une variante, à tester.
Cordialement.
Final.xlsm
(102.91 Kio) Téléchargé 5 fois
par Zebulon2
30 mars 2020, 18:48
Forum : Excel - VBA
Sujet : Fichier adhérent pour une association
Réponses : 3
Vues : 65

Re: Fichier adhérent pour une association

Bonsoir, Comment je peux faire pour appliquer ces formules à un tableau de 5000 cases ? Mettre ce tableau sous forme de tableau (au sens Excel) menu Accueil, Styles, Mettre sous forme de tableau. Insérer la formule de calcul dans la 1ère cellule de la colonne concernée, Entrée. Une icône apparait en...
par Zebulon2
30 mars 2020, 03:09
Forum : Excel - VBA
Sujet : Fichier adhérent pour une association
Réponses : 3
Vues : 65

Re: Fichier adhérent pour une association

Bonsoir,

Une proposition,
Cordialement.
par Zebulon2
28 mars 2020, 01:12
Forum : Excel - VBA
Sujet : Lien hypertexte dynamique avec renvoi sur cellule
Réponses : 3
Vues : 72

Re: Lien hypertexte dynamique avec renvoi sur cellule

Bonsoir,

Le dernier argument de la formule EQUIV, le 0 ou le 1 a été omis, d'où l'erreur de n° de ligne.

Il faut lire :
=LIEN_HYPERTEXTE("#DSI!"&ADRESSE(EQUIV([@COLONNE14];DSI!A:A;0);1);[@COLONNE14])
Cordialement.
par Zebulon2
26 mars 2020, 00:00
Forum : Excel - VBA
Sujet : =Somme qui ne fonctionne pas sur une colonne avec formule SI
Réponses : 4
Vues : 55

Re: =Somme qui ne fonctionne pas sur une colonne avec formule SI

Bonsoir,

Le problème vient de la formule =SI(E31="REPOS";"";SI(E31<=$E$38;"1";"")), le fait de mettre 1 entre "" indique à excel que cet élément est du texte. Supprime les guillemets et cela fonctionnera.
=SI(E31="REPOS";"";SI(E31<=$E$38;1;""))
Cordialement.
par Zebulon2
24 mars 2020, 19:38
Forum : Excel - VBA
Sujet : Tableau d'une feuille a l'autre
Réponses : 11
Vues : 142

Re: Tableau d'une feuille a l'autre

Bonsoir,

Le fichier joint dans mon dernier post contient la macro d'actualisation. Le choix dans une des deux listes déroulantes lance la macro d'actualisation.
Cordialement.
par Zebulon2
21 mars 2020, 20:00
Forum : Excel - VBA
Sujet : Remplissage automatique onglet
Réponses : 7
Vues : 99

Re: Remplissage automatique onglet

Re, C'est normal, j'utilise l'information de la colonne BAT dans la formule =SIERREUR(INDEX(T_Semaine[BAT];EQUIV(LIGNE(A1)&$M$2;T_Semaine[BAT]&T_Semaine[N°AFFAIRE];0));"") pour retrouver les lignes correspondantes à la référence Affaire. Il est possible de pallier au problème en utilisant une colonn...
par Zebulon2
21 mars 2020, 15:57
Forum : Excel - VBA
Sujet : Associer un nombre à une cellule selon la couleur de remplissage
Réponses : 9
Vues : 107

Re: Associer un nombre à une cellule selon la couleur de remplissage

Bonjour à tous, Une proposition avec la fusion de deux fonctions VBA. https://www.gcexcel.com/compter-les-cellules-de-couleur/ https://www.formuleexcel.com/compter-les-cellules-selon-leur-couleur-sur-excel/ Cela donne : =NbCellCouleur(C$3:C$14;couleur($B21)) Attention aux cellules fusionnées, elles ...