42 résultats trouvés

par jvdo
18 octobre 2019, 13:31
Forum : Excel - VBA
Sujet : Aide pour formule matricielle
Réponses : 3
Vues : 41

Re: Aide pour formule matricielle

Bonjour à tous,

Essaye :
en B18 : =RECHERCHEV("x";$A$14:$B$78;2;FAUX)
en B19 : =RECHERCHEV("x";$A$14:$B$78;2;VRAI)

cordialement
par jvdo
23 septembre 2019, 09:48
Forum : Excel - VBA
Sujet : Barre défilante dans un graphique
Réponses : 2
Vues : 125

Re: Barre défilante dans un graphique

Bonjour à tous,

Ta pièce jointe contient des noms/prénoms.
Anonymise la et retire la version actuelle.

Cordialement
par jvdo
14 septembre 2019, 13:14
Forum : Excel - VBA
Sujet : Disponibilité Emplacement
Réponses : 6
Vues : 149

Re: Disponibilité Emplacement

Bonjour à tous, Si tu veux une formule matricielle de type doliprane et d'une lenteur abyssale, en voici une : =SI(H2<>"Vide";"Occupé "&H2;SI(MOD(G2-MAX(SI((GAUCHE(Emplacement;12)=GAUCHE($A2;12))*(Emballage<>"vide");--Indice;0));RECHERCHEV(DECALER($H$1;MAX(SI((GAUCHE(Emplacement;12)=GAUCHE($A2;12))*...
par jvdo
3 juillet 2019, 12:36
Forum : Excel - VBA
Sujet : SommeProd et Définition de matrice
Réponses : 2
Vues : 93

Re: SommeProd et Définition de matrice

Bonjour à tous, Tu peux te passer de ton sommeprod() et utiliser la formule suivante qui factorise les calculs internes du sommeprod() : =$A$2*$B$1*$C$1*(1-$E$1)*(1-$F$1)*(1-((1-$E$1)*(1-$F$1))^500)/(1-(1-$E$1)*(1-$F$1)) Remarque : au cas où, tu remarqueras que E1 et F1 peuvent commuter. Cordialemen...
par jvdo
22 juin 2019, 17:44
Forum : Excel - VBA
Sujet : [VBA] - Vitesse d'exécution code VBA
Réponses : 11
Vues : 326

Re: [VBA] - Vitesse d'exécution du code

Bonjour à tous,

A première vue, tu devrais travailler sur des tableaux (tu mets C2:Clrco dans un tableau), tu travailles avec tes replace successifs sur le tableau et tu rapatries le résultat du tableau en C2:Clrco.

Ça devrait être immédiat en temps de réponse.

Cordialement
par jvdo
22 juin 2019, 00:45
Forum : Excel - VBA
Sujet : Gestion rencontre équipe
Réponses : 10
Vues : 286

Re: Gestion rencontre équipe

Bonsoir à tous, Si tu as 16 équipes, tu ne peux faire que 8 ateliers en même temps. Cela représente 64 matches sur les 120 que peuvent faire 16 équipes. Il y aura donc 54 matches qui ne seront pas affectés à des ateliers mais chaque équipe aura fait chaque atelier et il n'y aura aucun matches en dou...
par jvdo
21 juin 2019, 19:08
Forum : Excel - VBA
Sujet : Fonction : suffixe avec 2 possibilités
Réponses : 8
Vues : 216

Re: Fonction : suffixe avec 2 possibilités

Bonjour à tous,

Ne te fatigue pas trop, DjiDji59430, il a déjà des réponses ici.

cordialement
par jvdo
14 juin 2019, 10:10
Forum : Excel - VBA
Sujet : Paramétrer un Solveur avec VBA
Réponses : 22
Vues : 295

Re: Paramétrer un Solveur avec VBA

Bonjour, Regarde la formule de ta cellule cible ($G$80) que tu souhaites minimiser. c'est égal à : 30 + (Admin_GA/1500+Admin_GP/1500+Admin_GT/2500) + (Prod_GA/1500+Prod_GP/1500+Prod_GT/2500) + (Distri_GA/1500+Distri_GP/1500+Distri_GT/2500) Tous les numérateurs sont les valeurs des choix U1 ou U2 réa...
par jvdo
12 juin 2019, 10:11
Forum : Excel - VBA
Sujet : Paramétrer un Solveur avec VBA
Réponses : 22
Vues : 295

Re: Paramétrer un Solveur avec VBA

Bonjour à tous, Dans ce cas, pourquoi veux-tu utiliser le solveur? Une contrainte qui t'est imposée? Sinon, une simple formule t'indiquera le meilleur choix d'un domaine puisqu'il n'y a pas interdépendance entre tes 3 domaines. La somme des 3 meilleurs choix sera le meilleur choix d'ensemble. Pour "...
par jvdo
11 juin 2019, 14:49
Forum : Excel - VBA
Sujet : Paramétrer un Solveur avec VBA
Réponses : 22
Vues : 295

Re: Paramétrer un Solveur avec VBA

Cela pourrait tout simplement nous ( je m'associe à Pedro22) permettre de comprendre la structure de ton problème, d'éviter les hypothèses hasardeuses. On pourrait peut-être t'éviter d'utiliser le solveur ou te le paramétrer pour le passer en simplexe. Il faut connaître tes formules, chose qu'une im...