108 résultats trouvés

par relmo
1 avril 2019, 18:18
Forum : Excel - VBA
Sujet : Formule Somme.si.ens
Réponses : 10
Vues : 82

Re: Formule Somme.si.ens

oyobrans a écrit :
1 avril 2019, 18:15
=SOMME.SI.ENS($F$2:$F$7;$B$2:$B$7;"<"&DATE(ANNEE(B2);MOIS(B2);1);$C$2:$C$7;C2)
C'est exactement ça en effet!!

Merci beaucoup

Et merci à vous tous qui avez voulu me donner un coup de pouce
par relmo
1 avril 2019, 18:17
Forum : Excel - VBA
Sujet : Formule Somme.si.ens
Réponses : 10
Vues : 82

Re: Formule Somme.si.ens

Bonjour, Avec ceci ? =SOMME.SI($B$2:$B$7;"<"&DATE(ANNEE(B2);MOIS(B2);1);$F$2:$F$7) La formule en m'inspirant de la votre donnera donc ceci =SOMME.SI.ENS(F:F;C:C;C2;B:B;"<"&DATE(ANNEE(B2);MOIS(B2);JOUR(B2))) Merci beaucoup pour le coup de pouce.. Je comprend que je n'ai pas été bien clair dans la de...
par relmo
1 avril 2019, 18:10
Forum : Excel - VBA
Sujet : Formule Somme.si.ens
Réponses : 10
Vues : 82

Re: Formule Somme.si.ens

Bonjour à tous, :pdm: Un essai avec une colonne supplémentaire (qui peut être masquée), :lole: Copie de Exemple.xlsx Cordialement, Bonjour Xorsankukai Je me suis sûrement mal exprimé, c'était par exemple de faire pour tout ce qui est "Gateau" dans la colonne C la somme de tout ce qui a été perçu av...
par relmo
1 avril 2019, 18:07
Forum : Excel - VBA
Sujet : Formule Somme.si.ens
Réponses : 10
Vues : 82

Re: Formule Somme.si.ens

Bonjour, Avec ceci ? =SOMME.SI($B$2:$B$7;"<"&DATE(ANNEE(B2);MOIS(B2);1);$F$2:$F$7) Bonjour Oyobrans J'ai compris le sens de la formule je vais l'adpater. sinon la somme devrait se faire pour chaque nature de bien la somme de tout ce qui a été payé précédemment.. Avec un somme.si.ens adapté a votre ...
par relmo
1 avril 2019, 18:03
Forum : Excel - VBA
Sujet : Formule Somme.si.ens
Réponses : 10
Vues : 82

Re: Formule Somme.si.ens

Slt relmo, dans quelle céllule veux tu avoir la somme de tous les montants perçus avant le mois en cours? de préference ajoute dans ton document le résultat souhaiter, ca aide beaucoup :) Bonjour, C'est dans la colonne E que je voudrais obtenir ce résultat... C'est d'ailleurs pourquoi j'y ai inséré...
par relmo
1 avril 2019, 17:33
Forum : Excel - VBA
Sujet : Formule Somme.si.ens
Réponses : 10
Vues : 82

Formule Somme.si.ens

Bonjour à tous Je voudrais que vous m'aidiez a mettre une formule dans la colonne E de mon tableau (Voir Pj) de façon à faire : la somme de tous les montants perçus avant le mois en cours.. J'ai pensé à un somme.si.ens mais comment indiquer le critère 'Antérieur la date en cours" je n'y arrive pas j...
par relmo
19 mars 2019, 17:30
Forum : Excel - VBA
Sujet : Calcul de valeur en fonction des périodes choisies
Réponses : 3
Vues : 56

Re: Calcul de valeur en fonction des périodes choisies

i20100 a écrit :
19 mars 2019, 16:32
Bonjour,

à tester,
=SI(INDEX(L8:L10000;EQUIV(B3;B8:B10000;0))=0;INDEX(L8:L10000;EQUIV(B3;B8:B10000;0)-1);INDEX(L8:L10000;EQUIV(B3;B8:B10000;0)))
J'ai pas trop compris ca ne renvoie que la première valeur après avance
par relmo
19 mars 2019, 13:48
Forum : Excel - VBA
Sujet : Calcul de valeur en fonction des périodes choisies
Réponses : 3
Vues : 56

Calcul de valeur en fonction des périodes choisies

Bonjour à tous J'ai ce tableau que j'ai conçu Pour être plus pratique je voudrais l'automaitiser de manière à ce qu'il ne m'affiche que les résultats de la date que j'aurais sélectionné en B1 la difficulté réside dans des remboursements qui sont effectués, et le montant restant doit être calculé en ...
par relmo
9 février 2019, 13:32
Forum : Excel - VBA
Sujet : Recherche de cellules contenant #Valeur; #N/A etc
Réponses : 24
Vues : 240

Re: Recherche de cellules contenant #Valeur; #N/A etc

Re, Pour commencer, il faut mettre tes données sous forme de tableaux structurés. Il sont apparus avec Excel 2007, et depuis, on doit privilégier leur utilisation dès lors que l'on gère des données. Un lien à consulter : Merci Jean-Eric pour toutes ces précisons.. Les explications dans la macro son...
par relmo
9 février 2019, 11:11
Forum : Excel - VBA
Sujet : Recherche de cellules contenant #Valeur; #N/A etc
Réponses : 24
Vues : 240

Re: Recherche de cellules contenant #Valeur; #N/A etc

Jean-Eric a écrit :
9 février 2019, 09:37
Une mise à jour pour ne traiter que les feuilles Source A, Source B et Source C.
A te relire.
J'a quand même un petit soucis: je n'arrive pas à modifier , le nom ni les plages défini dans le gestionnaire des noms