2802 résultats trouvés

par R@chid
11 avril 2020, 22:25
Forum : Excel - VBA
Sujet : Power query cumul
Réponses : 23
Vues : 327

Re: Power query cumul

Re, Salut 78chris Merci Jean-Eric pour cet éclaircissement, ça m'a été vraiment très utile, je n'ai pas bien compris INDEX[] la première fois, je pensais que l'on tape Index[Col_Qte] pour avoir un index de la colonne Col_Qte et je ne savias pas que c'est le premier Index que l'on ajouté et qui a pri...
par R@chid
11 avril 2020, 20:23
Forum : Excel - VBA
Sujet : Power query cumul
Réponses : 23
Vues : 327

Re: Power query cumul

Re, Salut Jean-Eric, Bonjour, Un exemple. Cdlt. let Source = Excel.CurrentWorkbook(){[Name="Tableau1"]}[Content], Types = Table.TransformColumnTypes(Source,{{"DATE", type date}}), TriCroissant = Table.Sort(Types,{{"DATE", Order.Ascending}}), Index = Table.AddIndexColumn(TriCroissant, "Index", 1, 1),...
par R@chid
11 avril 2020, 18:55
Forum : Excel - VBA
Sujet : Power query cumul
Réponses : 23
Vues : 327

Re: Power query cumul

Bonjour,
vraiment je ne sais pas comment faire, mais je ne pense pas que tu auras besoin de Power Query pour faire un cumulé des quantités.
par R@chid
10 avril 2020, 22:35
Forum : Excel - VBA
Sujet : Extraire des adresses mails d'un fichier excel executant un tri
Réponses : 45
Vues : 400

Re: Extraire des adresses mails d'un fichier excel executant un tri

Bonjour @ tous,
:bv:
Je pense que tu comptes faire un publipostage avec pièce(s) jointe(s) personnalisée(s) {ou pas}.
Voir cette vidéo.
https://www.youtube.com/watch?v=wStN7ck_Hno


Cordialement
par R@chid
10 avril 2020, 22:11
Forum : Excel - VBA
Sujet : Cellules non vides et conditions
Réponses : 6
Vues : 114

Re: Cellules non vides et conditions

Bonjour @ tous,
Re,
CDB a écrit :
10 avril 2020, 18:14
Merci pour la réponse mais ce n 'est pas le résultat j'ai du mal m'exprimer.
Tu étais bien clair que possible, c'est moi qui n'ai pas bien lu la question, je suis désolé.
En B11
=SOMMEPROD((C$4:V$4=1)*(A$5:A$7=A11)*(C$5:V$7<>""))
@ tirer vers le bas


Cordialement
par R@chid
9 avril 2020, 23:41
Forum : Excel - VBA
Sujet : Cellules non vides et conditions
Réponses : 6
Vues : 114

Re: Cellules non vides et conditions

Bonsoir @ tous,
en B11 :
=SOMMEPROD(((C$4:V$4=1)+(C$4:V$4=4))*(C$5:V$7="")*(A$5:A$7=A11))
@ tirer vers le bas


NB:
Mettre les options de calculs des formules en Automatique.



Cordialement
par R@chid
11 mars 2020, 14:12
Forum : Excel - VBA
Sujet : NB.SI.ENS ou SOMME.PROD ou TCD ?
Réponses : 2
Vues : 38

Re: NB.SI.ENS ou SOMME.PROD ou TCD ?

Bonjour,
Il faut écrire SOMMEPROD() ainsi : =SOMMEPROD((Garant=M4)*(ANNEE(Dde)=M21))
Il n'y a pas de point entre les deux mots.
Pour ton TCD, il faut grouper les dates par année ou pas mois et année si tu veux.
zeldanat28_V1.xlsx
(39.65 Kio) Téléchargé 28 fois
Cordialement
par R@chid
8 mars 2020, 13:57
Forum : Excel - VBA
Sujet : Tableau combinaison possibilité
Réponses : 3
Vues : 103

Re: Aide sur excel

Bonjour @ tous,
:bv:
Si tu peux changer le titre de la discussion, ça va déjà t'aider à trouver des sujets similaires qui ont été traités.
Sinon, une âme charitable va surement passer par là pour te tisser une macro vba qui fera l'affaire.


Cordialement
par R@chid
7 mars 2020, 15:31
Forum : Excel - VBA
Sujet : Associé deux cellules
Réponses : 15
Vues : 159

Re: Associé deux cellules

Bonjour,
content de savoir que je vais dans le bon sens sans ma boule de cristal.
Tu sélectionnes la cellule contenant la valeur et tu lui donnes un nom, juste un nom t'as pas besoin de prénom.
2020-03-07_15-27-49.png
2020-03-07_15-27-49.png (29.96 Kio) Vu 22 fois
Cordialement
par R@chid
7 mars 2020, 00:14
Forum : Excel - VBA
Sujet : Associé deux cellules
Réponses : 15
Vues : 159

Re: Associé deux cellules

Re,
une deuxième proposition à tout hasard
Voir PJ
Lu38_V2.xlsm
(8.81 Kio) Téléchargé 29 fois
On ne peut nommer une cellule PM001 ou PM002, donc j'étais censé y ajouter le préfixe C_


Cordialement