246 résultats trouvés

par ouisansdoute
18 octobre 2019, 16:58
Forum : Excel - VBA
Sujet : numérotation auto avec critères
Réponses : 6
Vues : 227

Re: numérotation auto avec critères

Bonjour,

Une formule à tester en C3 :
=SI(ET(A3="";B3="");SI(C2="";1;C2+1);"")
A recopier vers le bas.
par ouisansdoute
22 septembre 2019, 11:09
Forum : Excel - VBA
Sujet : Recherche valeurs en fonction de situations différentes
Réponses : 2
Vues : 81

Re: Recherche valeurs en fonction de situations différentes

Bonjour, Quelques pistes : Pour les doublons avec la valeur C : =SI(ET(I2="C";I3="C";E2=E3;E2<>E1);M2;"") Pour les doublons avec des valeurs différentes en colonne I (Soit P et C soit C et P) : =SI(OU(ET(E2=E1;I2<>I1);ET(E2=E3;I2<>I3));M2;"") ça se complique avec les valeurs P mais je te propose : =...
par ouisansdoute
18 février 2019, 12:00
Forum : Excel - VBA
Sujet : Générer des codes barres EAN 128 dans excel
Réponses : 6
Vues : 1320

Re: Générer des codes barres EAN 128 dans excel

Bonjour, J'ai eu besoin de la même chose il y a quelques années. J'ai récupéré le fichier joint réalisé par Thierry Pourtier d'après un code de GranZebu. Il faudra que tu installes la police code barre qui va bien par exemple : http://www.dafont.com/fr/code-128.font Je pense que cela pourra répondre...
par ouisansdoute
5 septembre 2018, 17:43
Forum : Excel - VBA
Sujet : total chiffre journalier jours de la semaine, probleme avec =SOMME.SI
Réponses : 7
Vues : 203

Re: total chiffre journalier jours de la semaine, probleme avec =SOMME.SI

L'avantage avec mferrand c'est qu'en plus il est très pédagogue. Respects.
par ouisansdoute
5 septembre 2018, 13:47
Forum : Excel - VBA
Sujet : total chiffre journalier jours de la semaine, probleme avec =SOMME.SI
Réponses : 7
Vues : 203

Re: total chiffre journalier jours de la semaine, probleme avec =SOMME.SI

Bonjour,

Tu peux le faire avec la fonction SOMMEPROD suivante :
=SOMMEPROD((JOURSEM(A2:A31)=2)*(B2:B31))

2 pour lundi
3 pour mardi
4 pour mercredi
etc.
par ouisansdoute
5 septembre 2018, 11:27
Forum : Excel - VBA
Sujet : Erreur recherchev
Réponses : 4
Vues : 71

Re: Erreur recherchev

Bonjour, Attention : la valeur recherchée doit être dans la première colonne du tableau de recherche. Je pense que l'erreur vient de là. Par ailleurs, si tu dois recopier la formule vers le bas, il serait plus correct soit de nommer le tableau de recherche, soit de le mentionner en références absolu...
par ouisansdoute
24 mai 2018, 20:37
Forum : Excel - VBA
Sujet : integrer une condition dans une condition
Réponses : 4
Vues : 266

Re: integrer une condition dans une condition

J'étais allée un peu trop vite et ne l'avais pas testée.
Tant mieux si ca vous a mis sur la bonne voie.
par ouisansdoute
24 mai 2018, 19:17
Forum : Excel - VBA
Sujet : Graphique avec 2 séries distinctes
Réponses : 1
Vues : 112

Re: Graphique avec 2 séries distinctes

Bonjour, Des pistes : Il est possible de représenter deux séries différentes sur un même graphique avec des échelles différentes. Pour cela on utilise l'axe des ade droite et on définit une échelle personnalisée pour la seconde série. Cependant il faut que ton paramètre temps soit la même référence ...
par ouisansdoute
24 mai 2018, 18:59
Forum : Excel - VBA
Sujet : Si date superieure
Réponses : 10
Vues : 280

Re: Si date superieure

Bonjour,

Pour la dernière colonne vous pouvez essayer la formule suivante :
=SI(A5="";"";SI(L5="OK"; " Prévoir enlèvement"; " Marchandise à isoler"))

En recopiant la formule sur tout le tableau. Cette cellule n'aura aucune valeur tant que la date de relevé d'anomalie ne sera pas saisie.
par ouisansdoute
24 mai 2018, 18:54
Forum : Excel - VBA
Sujet : integrer une condition dans une condition
Réponses : 4
Vues : 266

Re: integrer une condition dans une condition

Bonjour,

Dans le fichier joint il n'y a rien en colonne B.

Une proposition cependant :
SI(B34<B40;1177-(B40*0,75)<=0;"0";1177-(B40*0,75);1177-(B34*0,75)<=0;"0";1177-(B34*0,75))