Résultats pour "esterreur vba"

8'732 résultats pour cette recherche

bonjour

je souhaite écrire cette fonction en vba. je n'arrive pas placer esterreur dans le IF

=SI(ESTERREUR(B3/A3)=VRAI;0;B3/A3)

merci de votre aide par avance

Philippe

Bonjour à tous,

J'ai une petite difficulté dans une formule :

J'utilise la fonction MOYENNE.SI mais il y a des #VALEURS! dans ma base de donnée liée à des valeurs manquantes. Mon calcul de moyenne me donne donc le résultat #VALEURS! .

Du coup j'ai tenté d'inserer la valeur ESTERREUR :

{=MOYENNE.SI(vitesses!$C$3:$C$162;"M1";SI(ESTERREUR(vitesses!E3:E162);"babla";vitesses!E3:E162))}

Mais ça n'a pas l'air de fonctionner...

Auriez vous une solution simple ?

Merci par avance.

Bonjour à tous et toutes,

J'ai un petit soucis et j'ai besoin de votre aide si vous le voulez bien.

J'ai terminé mon projet mais je cherche un moyen pour modifier quelque chose.

J'ai une formule qui fonctionne mais qui m'affiche le résultat en face de la ligne de mon tableau et j'aimerais qu'il m'affiche les résultats en ligne successive.

C'est difficile à expliquer je vous l'avoue (j'ai mis mon tableau exemple)

Je fais 2 choix dont la résultante est en ligne C3 et C6 par exemple. Il va m'afficher le résultat voulu en ligne D3 et D6 et j'aimerais qu'il m'affiche les résultats en D1 et D2. (Mon plus gros projet va se faire dans un fichier à part et ira chercher les données dans d'autres fichiers)

Merci d'avance pour toute l'aide apportée

Vianney

19classeur1.xlsx (11.50 Ko)

Bonjour,

je bataille sur Excel depuis quelques années, mais cette fois-ci je sèche...

je cherche à appliquer cette formule :

=SI(ESTERREUR(CHERCHE(C478;E2479));"Mot non trouvé";"Mot trouvé")

mais au lieu de limiter la recherche à une case (E2479) je veux chercher dans plusieurs case (E2479:E2583)

il ne me manque plus que ça pour avoir l'outils dont j'ai besoin !

merci de votre aide !

Bonjour à tous,

Je n'ai pas trouvé de solution à mon problème sur les forums, j'ai donc décider de m'inscrire sur celui-ci en espérant que quelqu'un pourra m'aider.

Mon problème concerne une feuille excel pour la consommation de carburant que j'ai joint au post.

Lorsque je fais un plein partiel je marque "p" dans la colonne B et j'aimerais que dans la colonne F la conso ne s'affiche pas (là elle affiche 0) et qu'elle se fasse au prochain plein.

Ma formule la plus aboutie se trouve dans F6:F8.

J'ai essayé avec la fonction ESTERREUR dans la case F9, mais je n'arrive pas à l'intégrer à ma formule qui se trouve dans les cases F6:F8.

Est'il possible d'intégrer cette fonction ou existe t'il une autre fonction ou méthode qui laisserait la case vide ?

Merci pour votre aide.

Bonjour,

Si quelqu'un peut venir à mon aide car je suis novice et jen'ai pas pris de cours..

Je voudrais que ma cellule A9 affiche :

  • si A8 contient "*Femelle*", que la cellule A9 = texte de la cellule U8
  • si A8 contient "*Ethnie*", que la cellule A9 = texte de la cellule U4
  • si A8 contient "*Male*", que la cellule A9 = texte de la cellule U5
  • si A8 contient "*Vie*", que la cellule A9 = texte de la cellule U6
  • si A8 contient "*Objet*", que la cellule A9 = texte de la cellule U7

J'ai essayé cette formule mais visiblement je n'ai pas compris et il me manque quelque chose... lol

=SI(ESTERREUR(CHERCHE(A8="*Femelle*";$U$8));$U$8;SI(ESTERREUR(CHERCHE(A8="*Ethnie*";$U$4));$U$4;SI(ESTERREUR(CHERCHE(A8="*Male*";$U$5));$U$5;SI(ESTERREUR(CHERCHE(A8="*Vie*";$U$6));$U$6;SI(ESTERREUR(CHERCHE(A8="*Objet*";$U$7));$U$7;"")))))

car si dans la cellule A8 j'ai "*Male*", ma cellule A9 affiche le texte de la cellule U8 au lieu de U5

Pouvez-vous m'aider SVP ?

Merci

Bonjour les experts.

Je cherche et recherche sans trouver l'erreur sur cette formule qui doit comparer chaque ligne (mais avec 2 colonnes) à un listing.

je m'explique :

  • dans mon onglet "043" j'ai un colonne BLS, une colonne POIDS et une colonne Vérificat°
  • dans l'onglet "listing", une liste de numéro de BLS et de poids.

Mon idée de départ étant de pouvoir comparer chaque ligne (exemple D12 et F12) a l'onglet "listing" et d'afficher "OK" si ces deux valeurs sont présente dans l'onglet "listing" (sur la même ligne.

il faut que cette formule trouve si la valeur de D12 et F12 et présente sur la même ligne de l'onglet "listing".

le BLS peux être présent sur plusieurs ligne aussi bien dans l'onglet "042" que "listing"

Voici la formule donner par "Amadéus "

=SI(ESTERREUR(RECHERCHEV(D12;listing!A:B;2;FAUX)=F12);"";"OK")

Merci de votre aide

Franck

bonsoir a tous et a toutes

je viens de faire une petite recherche sur le forum et je ne te trouve pas de reponse a la question que voici

j utilise cette formule =SI(ESTERREUR(CHERCHE("MATIN";A6));"non";"oui") pour verifier si le mot MATIN se trouve bien ds la cellule A6 Si la reponse est positive j obtiens oui ds la cellule B2 ds le cas contraire c est un non et cela fonctionne tres bien mais comment faire pour verifier plusieurs mots Exemple MATIN,MIDI,SOIR sur une plage de A2 a BB2 ?

pour etre plus precis

Si les 3 mots se trouvent sur la meme ligne de A2 a BB2 le mot OUI apparait en B2 ds le cas contraire c est le non et ceci meme si il y a des cellules vide ou contenant d autres valeur entre les 3 mots

. A-------- B--------C--------D--------E------ F------G..................

1

2 xxx------OUI---MATIN---SOIR----MIDI---pieds...................

Merci d avance pour vos futurs reponses

dsl je n ai pas de fichier xls que je peux joindre mais j espere que mon explication ainsi que l espece de petit schema ci dessus vs aidera a comprendre mon probleme.

Bonjour,

Cherchant à optimiser mes feuilles de calculs, je me demandais si vous aviez des "Best Practices" en la matière pour accélérer les calculs lorsqu'on a une multitude de formules, notamment des recherchev, etc..

Je voulais aussi savoir si l'utilisation de la formule SIERREUR était plus rapide que l'ancienne formule SI(ESTERREUR).

Merci pour vos avis!

Bonne soirée

Winitieas

Bonjour à tous, et merci d'avance à ceux qui m'aideront.

J'ai un colonne avec des adresse et je cherche une formule qui serait du genre

Si A1 contient le mot "Paris" ou "Toulouse" alors "ok" sinon (pas de paris ou toulouse dans l'adresse) "pas ok"

Merci d'avance

Bonjour le forum,

J'ai un problème avec l'utilisation de ESTERREUR.

Sur une feuille excel j'ai un tableau avec 3 logiciels info (A, B et C) et en face un rpix correspondant.

Dans un autre fichier excel j'ai un tableau avec un eliste déroulante pour choisir quel logiciel je veux mettre dans chaque cellule.

Dans une autre cellule je fais la somme des prix en fonction des logiciels chosis.

J'obtiens un #VALEUR! et je ne coprends pas pourquoi.

Code

=SI(ESTERREUR(RECHERCHEV(G56;Listes!$I$1:$J$4;2;0));"";RECHERCHEV(G56;Listes!$I$1:$J$4;1;0))+SI(ESTERREUR(RECHERCHEV(G57;Listes!$I$1:$J$4;2;0));"";RECHERCHEV(G57;Listes!$I$1:$J$4;2;0))

Je joinds un fichier pour exemple.

Merci

Cordialement

Bonjour à tous,

J'ai un fichier avec 3 colonnes :

  • colonne A : nom de l'évènement
  • colonne B : date de l'évènement
  • colonne C : finalisation du programme (date de la colonne B - 60 jours)

Dans la colonne C, j'ai indiqué la formule suivante :

=SIERREUR([@Date]-60;"")

La formule marche bien dans les 2 cas suivants :

1) Quand la date est complète (ex : 18/12/2011)

2) Quand elle est incomplète (ex : octobre)

Simplement, elle ne marche pas dans le dernier cas de figure : quand la cellule censée contenir une date est vide.

Cela me renvoie au résultat suivant : ######

J'aurais souhaité que quand la date n'est pas renseignée, la cellule n'affiche rien (même résultat que quand la date est incomplète).

Je me dis que je devrais utiliser la formule estvide mais je n'arrive pas l'incrémenter avec la fonction sierreur...

Je vous ai joint l'exemple dans un fichier.

Merci d'avance pour votre aide !

26dates.xlsx (11.89 Ko)

Bonjour le forum

Je veux poser des formules conditionnelles par combinaison de la fonction esterreur et cherche.

si dans la cellule B4 il y'a PACK ou CHEQUE ou VIREMENT. si le réultat est vrai que X s'affiche sinon que ce soit vide.

le test se fait dans la cellule B7.

Merci

Bonjour,

j'ai encore besoin de vos lumières!

j'ai cette formule: =SI($I10="";"";INDEX(DECALER(base;$I10;);EQUIV($F$5;DECALER(debiteur;$I10;);0);COLONNE()))

je voudrais insérer la formule ESTERREUR mais mon faible niveau en tableur m'empêche d'obtenir un résultat probant!

merci pour vos contributions

Bonjour,

J'ai dans mon tableau la formule suivante :

=SI(ESTERREUR(TROUVE("";'TCD Dashboard €'!A42));"";'TCD Dashboard €'!A42)

Le but est d'avoir l'intitulé de la ligne A42 de la feuille "TCD Dashboard" lorsque celui-ci existe. S'il n'existe pas j'aimerais avoir un blanc.

Cela fonctionne bien sauf que lorsque qu'il n'y rien d'écrit sur la ligne A42 j'ai "0" au lieu du blanc voulu.

L'erreur vient elle de ma formule ?

Merci beaucoup pour votre aide!

Bonjour,

J'ai la formule suivante :

=SI(ESTERREUR(TROUVE("/";'TCD Dashboard €'!A30));'TCD Dashboard €'!A30;"")

J'aimerais avoir l'intitulé de la cellule A30 située dans l'onglet "'TCD Dashboard €" seulement si cet intitulé contient "/". S'il n'y a pas de "/" j'aimerais ne rien avoir, ni #VALEUR!, ni zéro. Je voudrais la cellule vide. Visiblement ma formule comporte une erreur car ça ne fonctionne pas. Quelqu'un saurait me dire où je me suis trompé ?

Merci pour votre aide !

J'ai plusieurs problèmes.

J'ai déja fait une RECHERCHEV.

Je dois faire le traitement des erreur avec la fonction ESTERREUR.

J'essaie de l'inclure pour toutes mes fonctions déja existantes, mais je ne sais pas comment faire. Pourrais tu m'expliquer stp.

Voici mon exemple :

Il y a 2 feuilles : la 1ere avec des valeurs. Et la 2eme avec des RECHERCHEV.

J'ai supprimé une valeur pour vérifier si la fonction SI(ESTERREUR) dans la 2eme feuille fonctionne.

Et au lieu de me mettre une celulle vide (car dans la fonction SI(ESTERREUR) j'ai indiqué la valeur de l'erreur comme une celulle vide ""), il m'afiche un 0.

J'ai souligné les celulles correspondante pour que ce soit plus visible.

Et j'ai un autre problème. Quand je vais dans format===>Mise en forme conditionelle.

Je cherche a mettre en rouge les valeurs maximums d'une plage. Je selectionne la formule et je tape : =MAX(E4:E18) et je choisis la couleur rouge dans format. Et ensuite il me les selectionne toutes en rouge.

Voici le fichier d'exemple :

Merci beaucoup de votre aide. Je vous en serai jamais assez reconnaissant.

Bonsoir,

Je sais qu'il y a beaucoup plus simple (notamment en utilisant une cellule fixe dans le tableau, modifiable par VBA), mais, savez-vous s'il est possible de modifier du code VBA à l'aide d'un autre code VBA.

Par exemple, si j'ai un code simple :

Private Sub CommandButton2_Click()
Cells(9, 8).Value = Cells(6, 6).Value * (50 / 100) * (11.5 / 100)
End Sub

Puis-je agir sur les valeurs 50 / 100 ou 11.5 / 100

Je peux, par exemple, faire apparaître un UserForm, proposant de modifier certaines valeurs fixes qui s'appliquent à de nombreuses cellules dans le tableau. Si j'inscrit 22 dans le premier champ et 17 dans le second j'obtiendrais :

Private Sub CommandButton2_Click()
Cells(9, 8).Value = Cells(6, 6).Value * (22 / 100) * (17 / 100)
End Sub

Et le bouton en question produirait donc un calcul différent.

Bonne soirée !

Bonjour,

Malgré les explications déjà faites sur ce forum, notamment dans ces discussions :

https://forum.excel-pratique.com/viewtopic.php?t=53841

https://forum.excel-pratique.com/viewtopic.php?f=2&t=132483

Je ne parviens pas à faire fonctionner ce code :

Spoiler

où nm et prn = des string ; si nm = "Ti"et prn = "ta" alors le nom de la feuille est "ti_ta"

Sub CreateWsEvenMacro()
Dim a As Integer, b As Integer

'ActiveWorkbook.VBProject.VBComponents.Count

    With ActiveWorkbook(nm & "_" & prn).codeModule
    a = .countOfLines
        .insertLines a + 1, "Private Sub Worksheet_activate()"
        .insertLines a + 2, "Call Decharge_Usf"
        .insertLines a + 3, "Bandeau_actions.Show 0"
        .insertLines a + 4, "End Sub"
    End With
End Sub

Je n'ai pas d'erreur, il ne se passe juste rien car je pense qu'Excel ne trouve pas ce que je cherche.

Le problème vient d'ici :

ActiveWorkbook(nm & "_" & prn).codeModule

Que j'ai également essayé d'écrire :

ActiveWorkbook.VBProject.VBComponents(nm & "_" & prn).codeModule

Ou bien

ActiveWorkbook.VBProject.(nm & "_" & prn).codeModule

Savez-vous ce que je dois écrire pour qu'Excel trouve, dans le document, le nom de la feuille recherchée ?

Cela ne fonctionne pas non plus si je demande à ce qu'Excel génère une feuille toujours nommée "Feuil1", sur laquelle je lancerais la macro ci-après, que je renommerais après.

Mon document est tout imbriqué, alors pour extraire la partie du code qui m'intéresse et proposer un document pour l'exemple ça va me prendre un peu de temps, je vous le transmets dès que possible !

Merci de votre attention !

Bonne soirée

Hello le forum,

je bloque sur un problème ...

J'ai un tableau VBA avec n lignes et 4 colonnes, voici comment je l'alimente :

ReDim Tab_Filtre_Compta(1 To Last_Row_Compta, 1 To 4) 'Redimension le tableau sur 4 colonnes (Account, Débit, Crédit, Team&Emplo)

Compteur_Tab_Compta = 1 'Compteur Tableau
For Ma_Ligne_Affichee = 2 To Last_Row_Compta 'Boucle sur les valeurs des lignes visibles
        'si la ligne n'est pas filtrée alors on alimente notre tableau des valeurs (Account + D + C + CODE)
        If .Rows(Ma_Ligne_Affichee).Hidden = False Then Tab_Filtre_Compta(Compteur_Tab_Compta, 1) = .Cells(Ma_Ligne_Affichee, o): Tab_Filtre_Compta(Compteur_Tab_Compta, 2) = .Cells(Ma_Ligne_Affichee, y): Tab_Filtre_Compta(Compteur_Tab_Compta, 3) = .Cells(Ma_Ligne_Affichee, x): Tab_Filtre_Compta(Compteur_Tab_Compta, 4) = .Cells(Ma_Ligne_Affichee, z) & "_" & .Cells(Ma_Ligne_Affichee, k): Compteur_Tab_Compta = Compteur_Tab_Compta + 1
Next Ma_Ligne_Affichee

Maintenant ce que je veux faire c'est d'avoir une liste sans doublons de la colonne 4 de ce tableau et inscrire cette liste dans une feuille ....

Mon idée est de créer un dico qui va parcourir chaque valeur de ma colonne 4 et si la valeur n'est pas présente dans mon dico, elle est ajoutée ...

Mais à coder c'est une autre histoire

Pourriez-vous me donner un petit coupe de main svp.

Merci à vous.

R@g.

Recherches récentes

fonction erreuriserror vbaenlever tabulationmacro synthesejpgcompilationandpage suivante vbamodele emailouvrir modele email automatiquehttp viktorianews victoriancichlids htsrv login php redirect_to https www dvd access comouvrir modele emaillistbox multitcd sourcesrecherchev feuillesuivi candidatsrecuperer donnees externesrecuperer lien externeenregistrerformat lien externe