b

Membre habitué

Inscrit le :14/06/2013
Dernière activité :17/10/2019 à 13:39
Version d'Excel :2010FR
Lieu :paris
Messages
73
Votes
0
Fichiers
0
Téléchargements
0

Sujets créés par belsamis010975

DateForumSujetExtrait du message
16/10/2019 à 15:14Excel - VBARécupérer un mot selon une listeBonjour à toutes et à tous, voici mon problème, en colonne AC j'ai une liste de mot et en colonne T j'ai lignes avec des libellés d'écritures, j'aimerai que si un mot de la colonne T appartient en colonne AC mettre en colonne M le mot qui correspond a la colonne ac ex : Colonne M (donnée à reporter...
13/03/2019 à 16:25Excel - VBAValidation aprés remplissage usfVoici mon problème dans mon USF, mon code bloque, il me met systématiquement le msgbox malgré que tous mes champs soit rempli, j'ai regardé le code pourtant il fait bien allusion aux box indiqués, je comprend pas ? Par la suite je souhaiterai que les utilisateurs est la possibilité de modifier une e...
05/07/2016 à 17:35Excel - VBATextbox date en nombreVoici mes 2 problèmes, Sur l'onglet mécanique Le 1er : je souhaiterai transformer les textbox 4 et 6 en nombre, se sont des dates. Le format souhaité et "mar. 5 juil. 16" Le 2ème : Nous sommes 2 à utiliser le fichier je souhaiterai qu'à chaque fois que nous utilisons le USF 4 que les initiales s'ins...
02/07/2016 à 16:02Excel - VBACombobox encascade usfJ'ai 3 combobox en cascade sur un USF Marque model motorisation 1) Si possible quand je choisis la marque il me propose seulement les models et motorisation de la marque. 2) Une fois la marque choisi qu'il me propose seulement les motorisations du model. En sachant que la BDD est en feuille 2. Cordi...
01/07/2016 à 13:02Excel - VBA Bonjour problème avec L = .RangeJ'ai un useform qui me pose problème. Il bloque sur la ligne de commande L = .Range("a65536").End(xlUp).Row + 1 Je ne comprend pas Et mon 2ème problème je ne sais pas du tout comment faire pour que mes 2 frames puisse me mettre dans ma feuille oui ou non Je vous joins le fichier histoire de mieux co...
30/09/2014 à 17:14Excel - VBA Format numérique dans un useformVoici mon problème actuel, j'ai un useform avec beaucoup de textbox exactement 87 Pour le moment mon soucis. Je souhaiterai que les textbox soit en format numérique et non en texte. Pour les textbox de 4 à 34 et de 75 à 87 dans le useform Machines. Je suis perdu Cordialement Samy...
18/09/2014 à 11:25Excel - VBACombobox zelon conditionVoici mon problème, j'ai useform sur lequel il y a des combox. Je souhaiterai que : Si combobox9 (LCF / FD) = LCF alors la frame (PORTE FILTRE) soit coché sur old et la combobox14 (DOUCHETTES) = 4 trous Si combobox9 = FD alors la frame soit coché sur new et la combobox14 = 5 trous ou plastique blanc...
17/09/2014 à 14:29Excel - VBA Usseform modifications de donnéesBonjour à tous, a) Mon projet,le voici un formulaire qui permet de modifier des données d'une base existante et de créer de nouveaux client. Actuellement je bloque sur le UserForm_Initialize je n'arrive pas à faire en sorte que lorsque qu'on choisit un code SAP que toutes les données apparaissent au...
28/08/2014 à 16:10Excel - VBARemplir toutes les textbox selon conditionsBonjour à tous, J'ai un code qui fonctionne une fois sur 2. Lorsque que je rempli la partie du haut et que j'oubli une textbox il m'affiche un message. Lorsque la partie du bas est remplie rien n'est affichée Voici le code : Private Sub bt_valider_Click() Dim ctrl As Control, ctrlerr As Control Dim...
04/03/2014 à 11:04Calc Problème rechercheVVoici mon problème : En A21 = référence à rentrer En B21 = rechercheV de A21 ou C21 si l'une des 2 est vide pour obtenir libellé qui se trouve en colonne R En C21 = référence 2 à rentrer si A21 vide Ma base de référence est de P1 à U993 pour obtenir le libellé en colonne "R" Mon problème est si poss...
10/09/2013 à 15:09Excel - VBA Bloquer une cellule si la recherchev donneVoici mon soucis, en cellule B23 j’ai une RechercheV qui fait référence à B22. Je souhaiterais si possible, que si la RechercheV ne donne rien qu’elle me bloque en mettant un message d’erreur « erreur référence » en utilisant une validation de donnée. Car je vais devoir utiliser cette fonction en co...
05/07/2013 à 13:26Excel - VBA Validation de donnéesBonjour à tous, Voici mon problème du jour : En B25 j'ai une validation de donnée 3 choix possible."=SI(ESTNUM(CHERCHE("reprise";B20));mouv2;mouv1)" Si B20 contient "reprise" alors B25 = entrée. Maintenant je souhaiterai en plus de cette validation rajouter ceci, si B20 contient "Echange Standard" a...
28/06/2013 à 16:14Excel - VBA Validation de donnéesVoici mon problème il s'agit d'une validation de donnée: En B25 on a le choix entre : Entrée, sortie, Ech Std. En B20 si le mot "REPRISE" est écrit je souhaiterai que seul Entrée soit possible en B25. J'ai voulu mettre cette formule dans une liste Validation de données ça ne fonctionne pas. =SI(ou(E...
26/06/2013 à 17:11Excel - VBA Validation de donnéesBonjour à tous, Voici mon soucis: En cellule B24 j'ai crée une liste déroulante avec choix possible : Neuve; Occas.(validation de données) Maintenant j'aimerai compliquer la chose j'explique : B22 = Références produits B23=RechercheV pour le libellé produit B24= Neuve ou occas, grâce à une validatio...
14/06/2013 à 15:22Excel - VBA AIDE sur Fonction personnalisée en VBAJe suis notice en VBA, je souhaiterai adapter ce code à un mes fichiers, mes voila il y à un petit problème à ce code. Voici le code que je voudrais utiliser : Function SI_jaune(paye As Range, montant) Application.Volatile SI_jaune = " nul " 'Si FAUX If paye.Interior.color = 52377 Then SI_jaune = "...