Somme des valeurs si cellule suivante contient

j'ai un fichier de suivi de projet dans lequel nous notons le temps passé sur chaque dossier. Une ligne un dossier. chaque date contient plusieurs colonnes, mais surtout une colonne valeur suivi d une colonne avec du texte; toujours les 7 mêmes textes (validation de données). au bout de deux ans ca fait trop de colonnes pour pas grand chose. Afin d’alléger mon fichier je voudrais récupérer les sommes des temps passés sur une année. donc avoir une formule type somme.si qui pour chaque cellule à additionner vérifierait le contenu de la cellule suivante. Pour plus de clarté je vous mets un fichier exemple

4exemple.xlsx (8.72 Ko)

Bon ben si j'avais cherché tout seul avant de poster hein ..... pour que ca puisse etre utile à d'autres : =SOMME.SI.ENS(plage;DECALER(plage;0;1);cellule critere)

En utilisant la fonction DECALER, chaque cellule de la plage va vérifier la cellule décalée de cette même plage :)

Bonjour

Ceci marche aussi

=SOMME.SI.ENS($P$1:$AN$1;$Q$1:$AO$1;B1)

On decale soi-même la plage dans la formule (copiable sur chaque cellule verte)

bonjour

une contribution avec des explications

cordialement

6chnoub.xlsx (12.06 Ko)
Rechercher des sujets similaires à "somme valeurs suivante contient"