Signe "-" mais chiffre non négatif?

Bonjour le forum,

dans fichier ci-joint je doit faire des additions, mais les cellules à signes - ne sont signifient pas un chiffre négatif?

Une solution SVP?

16classeur1.xlsx (10.27 Ko)

bonjour

voir si cela convient

cdlt

17classeur1b.xlsx (9.77 Ko)

Bonjour,

29v1.xlsx (10.59 Ko)

A tester.

cdt

re,

Merci eric570, et merci pour la formule ketamacanna

I y a t'il une possibilité de transférer le signe moins "-" du droit du chiffre à sa gauche carrément?

Crdt

re

toujours sans formule avec mise en forme des cellules

fichier ci joint

cdlt

13classeur1b.xlsx (9.72 Ko)

Bonjour,

Avec un format de cellule personnalisé

"-        " Standard

Leakim

ps : on peut simplifier la formule que j'ai fournie:

=SOMME(SI(DROITE(A3:A6;1)="-";-SUBSTITUE(A3:A6;"-";"")*1;A3:A6))

cdt

Bonjour le forum,

ketamacanna, la formule ne fonctionne plus chez mois. je ne sais pourquoi.

Par contre je ne comprend pas ta solution de leakim!

Je joint donc le fichier sur quel je travail. "voir colonne E"

Une solution l'équipe?

3classeur1.xlsx (21.61 Ko)

Re le forum,

Voilà avec un peux de réflexion je revient avec la solution inspirée de la formule de "ketamacanna"

Remerciements

4classeur1.xlsx (40.54 Ko)

Bonjour,

La formule serait plutôt :

=SI(E3="";"";SI(DROITE(E3;1)="-";-SUBSTITUE(SUBSTITUE(E3;".";",");"-";"")*1;SUBSTITUE(E3;".";",")*1))

En fait, il faut remplacer également : les "points" par des "virgules"

cdt

Rechercher des sujets similaires à "signe chiffre negatif"