Quelle Formule utilisée

3test.xlsx (24.49 Ko)

Bonjour à tous,

Désolé de vous déranger, je souhaite améliorer mon fichier en pièce jointe svp,

L’idée est la suivante:

j'ai un transporteur qui me facture le prix en fonction de tranches du poids jusqu'à 100kg

( j'ai réussi à créer une formule avec =INDEX) pour calculer le tarif en dessous de 100kg

MAIS : à partir de 100Kg le transporteur arrondi le poids à une 10kg supérieur

Exemple : si le poids de marchandise est de 157kg

le prix se calcule de cette façon: 157kg devient en l'arrondit à la dizaine 160kg, le prix = 1,6 * 104,96€

104,96€ correspond au prix de 100kg

je souhaite créer une formule qui me permet de faire le calcul sur les poids qui dépasse les 100kg svp

Merci d'avance

Salut, essaye avec ça :

=SI(A1<100;A1*($E$1/100);ARRONDI.SUP(A1/10;0)*10*($E$1/100))

Avec en A1 ton poids, et en E1 ton prix pour 100kg (ici 104.96)

Bibu

Bonjour

Il est conseillé de travailler en tableaux structurés et déconseillé d'utiliser une plage dans EQUIV

Une autre solution

5tarifs.xlsx (23.89 Ko)
Rechercher des sujets similaires à "quelle formule utilisee"