Incrémenter n° de feuille dans une formule

bonjour à tous

J'ai cette formule qui fonctionne bien

=RECHERCHEV(D$1;'[2020_JANVIER.xlsx]01'!$A$1:$R$31;9;FAUX)

Le "01" fait référence à une feuille dans le fichier.

Comment-puis incrémenter ce numéro quand je tire la fonction ?

Bonjour,

Je dirais sans grande conviction :

=RECHERCHEV(D$1;INDIRECT("'[2020_JANVIER.xlsx]"&TEXTE(LIGNE(D1);"00")&"'!$A$1:$R$31");9;FAUX)

Cdlt,

Non ca ne fonctionne pas j'ai l'impression que c'est un peu la limite sur Excel.

Je pourrai simuler la saisie des formules via un script python ca serait plus simple.

Merci de ton aide :)

Bonsoir,

Ou alors c'est la limite des demandes sans le fichier concerné (ou du moins un extrait).

Avant de remettre en cause les capacités d'Excel, commençons par remettre en cause les nôtres ...

Bonjour désolé pour le retard de réponse je suis à Tahiti donc inversé niveau horaire.
Voici le tableau avec la formule qui va chercher des résultats sur une feuille différente à chaque nouvelle ligne.
Ligne 1 on va chercher sur la feuille 01
Ligne 2 on va cherche sur la feuille 02
ect
1classeur1.xlsx (12.72 Ko)

Bonjour,

Bizarre j'obtiens quelque chose avec cette formule pourtant en G2 :

=RECHERCHEV(D2;INDIRECT("'"&TEXTE(LIGNE(D2)-1;"00")&"'!$A$1:$R$31");9;FAUX)

Si je mets "x" en A16 et 3 en I16 de la feuille 01 alors c'est bien 3 qui est renvoyé en G2 de la feuille Feuil1. Idem si je fais la même manipulation sur une autre ligne sur la feuille 02 et que je tire la formule en G2 vers le bas.

Si vous avez votre Feuil1 dans classeur distinct des feuilles 01, 02, etc ... C'est un autre problème.

Cdlt,

Bonjour merci de ton aide

Je réexplique mon souci j'ai du mal m'expliquer.

Classeur 1 j'ia mes formule qui vont chercher des informations avec =SI(AD5="X";SI(ESTERREUR(RECHERCHEV(D$2;'chemin_fichierJANVIER.xlsx]01'!$A$5:$Q$31;13;FAUX));"";(RECHERCHEV(D$2;'F:\TOK\Tracabilite_contention_isolement\[2020_JANVIER.xlsx]01'!$A$5:$Q$31;13;FAUX)));)

Ca ca fonctionne nickel ca va chercher les informations dans d'autres classeurs.

Le souci c'est que pour chaque ligne la formule va chercher non seulement dans un autre classeur mais aussi dans une autre feuille.

=SI(AD5="X";SI(ESTERREUR(RECHERCHEV(D$2;'chemin_fichierJANVIER.xlsx]01'!$A$5:$Q$31;13;FAUX));"";(RECHERCHEV(D$2;'F:\TOK\Tracabilite_contention_isolement\[2020_JANVIER.xlsx]01'!$A$5:$Q$31;13;FAUX)));)

=SI(AD5="X";SI(ESTERREUR(RECHERCHEV(D$2;'chemin_fichierJANVIER.xlsx]02'!$A$5:$Q$31;13;FAUX));"";(RECHERCHEV(D$2;'F:\TOK\Tracabilite_contention_isolement\[2020_JANVIER.xlsx]02'!$A$5:$Q$31;13;FAUX)));)


=SI(AD5="X";SI(ESTERREUR(RECHERCHEV(D$2;'chemin_fichierJANVIER.xlsx]03'!$A$5:$Q$31;13;FAUX));"";(RECHERCHEV(D$2;'F:\TOK\Tracabilite_contention_isolement\[2020_JANVIER.xlsx]03'!$A$5:$Q$31;13;FAUX)));)

Ca je peux le faire en python et simuler la saisie des formules mais je me demande si Excel peut le faire sans passer par un autre soft.

Merci de ton aide :)

Bonjour,

Oui,j'avais vu sur ton autre post que c'était une formule qui portait sur plusieurs fichiers...

Heureusement, Ergotamine est un des nouveaux spécialistes de PowerQuery.

Nativement les fonctions indirect et les fichiers fermés ne font pas bon ménage.

Bonjour,

Avec vos fichiers sources ouverts comme l'a suggéré JoyeuxNoel :

=RECHERCHEV(D2;INDIRECT("'F:\TOK\Tracabilite_contention_isolement\[2020_JANVIER.xlsx]"&TEXTE(LIGNE(D2)-1;"00")&"'!$A$1:$R$31");9;FAUX)

Si vous ne souhaitez pas ouvrir vos fichiers je ne pourrais rien faire de plus désolé, les liaisons entre classeur et l'adaptation des formules, très peu pour moi.

Bon courage.

Cdlt,

PS : @JoyeuxNoel : Je ne sais même pas comment je pourrais reconstituer un chemin via PQ en DAX .. Ca dépasse très largement mes compétences. Tout aura été dans la même table structurée, une jointure et c'est reglé mais là chaque ligne est sur une source/feuille différente .. Ca devient une toile d'araignée. Bon courage à celui qui s'y collera ..

Oui je sais que la structure des fichiers fait un peu nébuleuse.

Je vais tout simplement automatiser la rédaction des fonctions et là je pourrai incrémenter ma référence aux feuilles :)

Un coup de Python et ca va poser aucun souci.

Logiciel : Automate BPA

Rechercher des sujets similaires à "incrementer feuille formule"