Formule pour chercher mot dans une cellule contenant une phrase

Bonjour,

Merci d'avoir pris le temps de lire mon post

J'ai 2 colonnes, une qui contient des mots et l'autres des phrases. J'ai supprimé toutes les majuscules et les espaces pour faciliter le traitement.

Colonne A1 = pomme Colonne B1=tarteauxpommechaude

Je cherche la formule qui me permet de chercher A1 dans B1

J'ai cette formule : =RECHERCHEV(A1;$B$1:$B$100;1;0) mais cela me marche pas car il faudrait que l'ensemble des caractéres soient présent dans les 2 colonnes :/

Un immense merci pour votre aide !

Salut,

Si tu fais en C1 : =TROUVE(A1;B1)

Dans le cas ou la formule renvoie un chiffre : le mot en A1 existe dans B1, si la formule renvoie #VALEUR! Il n'existe pas.

En espérant avoir aidé,

Girodo,

Bonjour croucrou,

testez les deux solutions ci dessous :

=TROUVE(A1;B1)

dans laquelle il faut respecter la casse majuscules / minuscules

OU

=CHERCHE(A1;B1)

dans laquelle la casse n'a pas d'incidence

Merci infiniment pour votre aide

Malheuresement ça ne fonctionne pas :/

C'est dans une colonne entiére que je dois chercher

Je met un exemple en PJ

Je dois savoire si un mot de la colonne B se trouve en A1 puis A2 ...

5maquette-v6.csv (571.00 Octets)

Bonjour croucrou,

Voyez dans le fichier joint

njhub a été plus rapide ! J'allais proposer comme lui de transposer les mots à chercher par colonnes.

Bonne journée,

Trop bien !

Vraiment un gigantesque merci pour votre aide

Rechercher des sujets similaires à "formule chercher mot contenant phrase"