Formule Nombre jours dans l'année

Bonjour à tous,

En ayant 2008 en A1

comment trouver le nombre de jours en A2 (soit 366) ?

en tâtonnant j'arrive à çà, mais quand pensent les formulistes ?

=DATE(A1+1;1;1)-DATE(A1;1;1)

Bonne journée

Claude.

Bonjour,

Ta formule me semble correcte.

Si tu utilisais Openoffice.Calc, je t'aurais proposé d'utiliser la fonction ESTBISSEXTILE(date).

En voici une autre formule :

=SI(ET(MOD(A1;4)=0;OU(MOD(A1;100)<>0;MOD(A1;400)=0));366;365)

mais elle est + complexe que la tienne.

A+

20zeturf-cotes.xlsm (81.72 Ko)

Bonjour,

Une autre formule avec un caractère de moins :

=DATE(A1;12;31)-DATE(A1;1;)

le 0 est facultatif dans les paramètres d'une fonction.

Une autre, un peu capillotractée :

=SOMMEPROD((JOUR(DATE(A1;LIGNE(INDIRECT("1:12"));0)))*1)

@+

capture d ecran 2018 08 27 a 18 10 28 capture d ecran 2018 08 27 a 18 11 55

Merci les amis,

çà me conforte, finalement je conserve ma formule

Bonne fin de journée

Claude.

re,

En reprenant comme Oooiste le principe des années bissextiles :

=365+(MOIS(DATE(A1;2;29))=2)

Pas plus courte

@+

Rechercher des sujets similaires à "formule nombre jours annee"