Compter avec critere sans doublons

Bonjour,

je tourne en rond et ne trouve pas la solution a un problème de comptage.

j'ai en colonne A des noms et prénoms

j'ai en colonne B des noms d'applications

j'ai en colonne C des status de vérification (a jour / a vérifier)

il existe de nombreuses autres colonnes mais elles ne sont pas utiles pour la formule qui me pose problème

une personne peut utiliser plusieurs application et donc apparaitre plusieurs fois dans le tableau

lorsque je fait le point avec un utilisateur je met a jour toutes les lignes qui le concernent.

je souhaite avoir comme indicateur de progressions :

le nombre d’utilisateur uniques =SOMMEPROD((Tableau132[NOM et Prénom]<>"")/NB.SI.ENS(Tableau132[NOM et Prénom];Tableau132[NOM et Prénom]&""))

le nombre de lignes total =NBVAL(Tableau132[NOM et Prénom])

le nombre de lignes a mettre a jours =NB.SI(Tableau132[Etat];"A Verifier")

le nombre d'utilisateur unique a mettre a jour Je ne trouve pas comment faire

voici un exemple de ce que pourrait être mon fichier :

DUPON Jean | Excel | a jour

DUPON Jean | Word | a jour

MERON Paul | Excel | a Vérifier

MERON Paul | Word | a Vérifier

MERON Paul | Access | a Vérifier

MARTIN Luc | Word | a Jour

MARTIN Pierre | Excel | a Vérifier

KATA Jim | Word | a Vérifier

Bonjour,

Encore mieux que de décrire ce que pourrait éventuellement être ton fichier ...

Le joindre ...

Re,

Ci-joint ton fichier test ...

Merci @James007

le fichier test que tu as envoyé fait exactement ce que je cherche, reste plus qu'a implémenter cela sur mon fichier de travail

salut James

et celle ci sur ton fichier (merci pour lui)

=SOMMEPROD((1/NB.SI(A2:A10;A2:A10)*(C2:C10=F2)))

cordialement

Merci @James007

le fichier test que tu as envoyé fait exactement ce que je cherche, reste plus qu'a implémenter cela sur mon fichier de travail

De rien ...

Mais je t'avoue avoir fait une vraie vraie exception ...

Car je n'ai pas envie de reconstruire de zéro tous les fichiers tests des demandeurs ...

Je suis sûr que tu me comprends ...

De rien ...

Mais je t'avoue avoir fait une vraie vraie exception ...

Car je n'ai pas envie de reconstruire de zéro tous les fichiers tests des demandeurs ...

Je suis sûr que tu me comprends ...

Je comprend je ferais en sorte de fournir un sample de test la prochaine fois

salut James

et celle ci sur ton fichier (merci pour lui)

=SOMMEPROD((1/NB.SI(A2:A10;A2:A10)*(C2:C10=F2)))

cordialement

j'aime beaucoup aussi cette formulation qui évite les matrices et reste dans le ton de ce que j'avais déjà.

au boulot certaines personnes aime jouer avec les formules et ne pense pas au CTRL+Maj+Enter du coup les calcul a base de matrices affichent souvent #VALEUR

encore une fois merci a tout les deux, vous me sortez une épine du pied.

le sujet est résou

le sujet est résou

Tant mieux ... une épine en moins ... surtout qu'il y a moins de 2 heures ... il manquait 2 solutions ...

je tourne en rond et ne trouve pas la solution a un problème de comptage

Rechercher des sujets similaires à "compter critere doublons"