Calculer nb de jours entre 2 dates incluant la date de début

Bonjour !

Je souhaiterais pouvoir calculer le nombre de jours entre 2 dates d'une même cellule ( c'est-à-dire que j'ai ma date de début et ma date de fin dans la même cellule ).

Jusqu'ici, tout va bien, avec les fonctions =GAUCHE, =DROITE, =DATEDIF, =NB.JOURS.OUVRES ....

Mon problème est qu'avec ces fonctions, excel ne me compte pas le jour de fin inclu. C'est-à-dire que pour une tranche allant du 20/02/2014 au 25/02/2014, je n'obtient que 5 jours au lieu de 6.

J'ai réussi à obtenir le bon nombre de jours en ajoutant "+1" à la fin de ma formule.

Mais lorsque je n'ai pas de jours ( c'est un grand tableau avec des cellules directement programmées avec des formules), donc que ma cellule est vide, il me compte bien évidemment 1 jour.

Comment faire pour ne pas à avoir à utiliser le "+1" ? Est-ce qu'il existe une formule qui compte directement la date de début et la date de fin ??

Merci d'avance !

Tu peux tester les cellules contenant des dates :

Si(ou(cellule_date_debut="";cellule_date_fin="");"";sinon_ta_formule)

cdt


Tu peux tester les cellules contenant des dates :

Si(ou(cellule_date_debut="";cellule_date_fin="");"";sinon_ta_formule)

Sinon merci de joindre ton fichier

cdt

Bonjour,

Mon problème est que mes dates ne sont que dans une seule et même cellule.

Je te joint mon fichier.

19horaires.xlsx (8.77 Ko)

Un essai :

32horairesv1.xlsx (9.56 Ko)
=SI(NB.SI(A1;"*au*")=1;(DROITE(A1;10)-GAUCHE(A1;10))+1;0)

Super merci beaucoup pour ton aide !!

Pourrais-tu m'expliquer le résonnement de ta formule ?

Car quand je n'ai qu'une date, ça me met "0" au lieu de "1" jour

Bonjour,

A tester.

=SI(NB.SI(A1;"*au*")=1;(DROITE(A1;10)-GAUCHE(A1;10))+1;SI(OU(A1=0;A1="");0;1))

Ça fonctionne seulement si j'ai qu'un jour.

Néanmoins, si j'en ai 0, ça me met 1 jour... Retour au premier problème , c'est un vrai casse tête !

15horairesv1.xlsx (9.06 Ko)

Re,

Formates correctement la colonne A.

Dans ton exemple 0 n'est pas un chiffre mais du texte...

Ou alors

=SI(NB.SI(A1;"*au*")=1;(DROITE(A1;10)-GAUCHE(A1;10))+1;SI(OU(A1=0;A1="0";A1="");0;1))

C'est bon j'ai reformater ma cellule !

Merci beaucoup pour ton aide !

Rechercher des sujets similaires à "calculer jours entre dates incluant date debut"