Calcul somme de nombre créer d'une formule

Bonjour à tous,

Voilà j'ai un tableau avec une colonne qui est créé à partir de la fonction Si : (formule : =SI(H16="";"";4)

Cette formule je la retrouve toutes les 4 colonnes

Dans une autre colonne je souhaiterais faire la somme (des nombre) de toutes les colonnes contenant la fonction si

Ors quand je fais la somme de toutes les cases contenant le chiffre 4 ou il me mets #Valeur!

=F16+J16+N16+R16+V16+Z16+AD16+AH16+AL16+AP16+AT16+AX16+BB16+BF16+BJ16+BN16+BR16+BV16+BZ16+CD16+CH16+CL16+CP16+CT16+CX16+DB16+DF16+DJ16+DN16+DR16+DV16+DZ16

Quelle est la fonction que je dois utiliser pour faire la somme des valeurs contenus dans toutes ces cellules.

Merci d'avance

Sabine

Bonjour

"" est du texte non géré par une addition arithmétique donc soit tu utilises 0 dans le formule SI et non "", soit tu modifies l'autre formule

=Somme(F16;J16;N16;R16;V16;Z16;AD16;AH16;AL16;AP16;AT16;AX16;BB16;BF16;BJ16;BN16;BR16;BV16;BZ16;CD16;CH16;CL16;CP16;CT16;CX16;DB16;DF16;DJ16;DN16;DR16;DV16;DZ16)

Mais il y a plus simple pour faire la somme d'une cellule sur 4

=SOMMEPROD((MOD(COLONNE(F16:DZ16);4)=2)*1;F16:DZ16)
Rechercher des sujets similaires à "calcul somme nombre creer formule"