Calcul de temps passé entre deux dates et heures

Bonjour,

Je me casse la tête sur une formule afin de calculer le temps passé entre 2 cellules avec date et heure.

Il faut que j'exclu les jours non ouvrés, et idéalement que je tienne compte des heures d'ouverture et de fin de mon équipe. (service ouvert de 9h à 18h du lundi au vendredi).

En résumé, la différence de temps entre la colonne B et la colonne A.

J'ai cherché et testé plusieurs propositions sans succès.

J'arrive à extraire le temps écoulés brutes mais pas en tenant compte des jours ouvrés et des heures d'ouverture et fermeture.

Pouvez-vous m'apporter votre aide svp?

Je partage le fichier

9forum-excel.xlsx (9.69 Ko)

Bonjour Audrey, bienvenue sur le forum !

La prochaine fois pour espérer une réponse plus rapide postez sur la partie du forum dédiée au Excel-VBA (Ce n'est pas que du VBA c'est pour tout ce qui concerne Excel)

Je suis pas un pro du format heure sur Excel mais je vous propose cette formule à faire glisser:

=SIERREUR(SI(MINUTE(B2)-MINUTE(A2)<0;((NB.JOURS.OUVRES(A2;B2)-1)*($F$3-$E$3))+(HEURE(B2)-HEURE(A2))-1;((NB.JOURS.OUVRES(A2;B2)-1)*($F$3-$E$3))+(HEURE(B2)-HEURE(A2))) & " heures et " & SI(MINUTE(B2)-MINUTE(A2)<0;60+MINUTE(B2)-MINUTE(A2);MINUTE(B2)-MINUTE(A2)) & " minutes";"")

Veillez à rentrer des entiers dans les cellules E3 et F3 soit 9 et 18

A+

Bonjour,
Une autre proposition.
Ne prend pas en compte les jours fériés.
Cdlt.

2forum-excel.xlsx (13.13 Ko)
Rechercher des sujets similaires à "calcul temps passe entre deux dates heures"