Calcul de la valeur des voyelles en numérologie

Bonjour,

Je voudrais que quand j'écris les prénoms + le nom de famille Excel me calcul tout seul le total de la valeur des voyelles.

Je vous joins mon fichier pour vous montrer.

Si vous pouviez m'aider car la je suis coincée.

Merci par avance

17classeur1.xlsx (10.56 Ko)

Bonjour,

Ci-dessous ce que je te propose (fait rapidement), n'hésites pas à faire un retour si besoin ou à modifier le code toi même.

Zapsalis,

5classeur1-1.xlsm (24.07 Ko)

Bonjour

En mettant les lettres dans des cases séparées tu te compliques l'existence avec 2007

Sur 365

=SOMMEPROD((STXT(JOINDRE.TEXTE(;;G4:W6;G8:W8);LIGNE(INDIRECT(1&":"&NBCAR(JOINDRE.TEXTE(;;G4:W6;G8:W8))));1)={"A"."E"."I"."O"."U"."Y"})*(MOD(CODE(STXT(MAJUSCULE(JOINDRE.TEXTE(;;G4:W6;G8:W8));LIGNE(INDIRECT(1&":"&NBCAR(JOINDRE.TEXTE(;;G4:W6;G8:W8))));1))-65;9)+1)*1)

donne 46

Je te laisse remplacer

JOINDRE.TEXTE(;;G4:W6;G8:W8)

par une concaténation case par case...

Merci Zapsalis,

Je n'ai pas pu activer le code donc ça ne marche pas, dommage :)

Merci quand même

Coucou 78chris,

Je viens d'essayer mais je n'ai rien compris désolée, je pense que c'est trop compliquer pour moi.

Du coup je n'es pas réussi, tu aurais quelque chose de plus facile ?

Merci en tout cas

Michelle

bonjour

donc du plus facile qui repond en principe pour ton exemple

=SOMMEPROD(NB.SI(G4:S8;{"a";"e";"y";"i";"o";"u"})*CODE({"a";"e";"y";"i";"o";"u"}))

cordialement

Bonsoir à tous !

donc du plus facile qui repond en principe pour ton exemple

Une "tulipienne" accessible.....votre (brève) absence a été salutaire.

Merci Tulip_4,

Voila ça donne ça 1129 : Alors que le total des voyelles devrait donner 46, du coup je comprends pas

2

re

quà ça ne tienne

=SOMMEPROD(NB.SI(G4:S8;{"a";"e";"y";"i";"o";"u"})*{1;5;7;9;6;3})

cordialement

Merci beaucoup Tulipe_4,

C'est génial ça marche, je suis contente encore merci :)

Re coucou Tulipe_4,

Peu tu m'aider encore : Voila c'est super par contre je voudrais que à chaque fois que mon total de voyelles est supérieur à 9 pouvoir l'arrondir.

Ex. : La le résultat c'est 12 et bien faire 1 + 2 = 3, par contre ne pasle faire si le chiffre trouvé est 11 ou 22

J'espère que je me suis bien expliquer

3

bonjour

donc si le total est >9 on décortique puis on réaditionne , sauf si le total = 11 ou 22

en résumé ,le resultat peut être 11 ou 22 ou la somme du décorticage

confirme

Bonjour Tulipe_4,

Oui c'est ça :), mais du coup je fais comment ?

Je remets le fichier Excel si ça peut aider

3classeur1.xlsx (13.66 Ko)

bonsoir

un essai pour ton exemple ,,, ça à l'air de gazer

SI(OU(Y6=11;Y6=12);Y6;SI(NBCAR(Y6)=2;GAUCHE(Y6)+DROITE(Y6);(GAUCHE(Y6)+DROITE(Y6))/2))

cordialement

Coucou Tulipe_4,

Je viens d'essayer et le code reste marqué tel quel, c'est bizarre. Il faut le mettre ou ?

4

bha ,tu le mets ou tu veux ; mais sans oublier le =

Désolée Tulipe_4,

Oui j'avais oublier le =

Mais ça m'écrit toujours 12, c'est supérieur a 9.

Moi ce que je voudrais c'est que quand le résultat est supérieur a 9;

par exemple 12 et bien que ça me face 1+2= 3 (et donc que ça m'affiche que le 3)

Sauf pour le 11 et le 22 que ça me le laisse tel quel, oui je sais je suis compliqué

re

dans la formule ,je me suis gourré ,, remplace 12 par 22

cordialement

Bonsoir Tulipe_4,

C'est super gentil de m'aider, vraiment merci

J'ai mis 22 à la place du 12 mais le résultat est toujours 12, cela ne m'a pas réduit le 12 par 3 ( 1+2=3)

bonjour chelle2, tulipe_4,

une proposition

=SI(OU(Y6=11;Y6=22);Y6;SI(MOD(Y6;9)=0;9;MOD(Y6;9)))
Rechercher des sujets similaires à "calcul valeur voyelles numerologie"