Pouvoir faire une moyenne

Bonjour, je débute sur les tableurs, je dois réaliser une moyenne sur un ensemble de note, par exemple math 12 français 5 histoire 13 etc. Le problème est que l'EPS est particulier, si la note est inférieur à 10 elle n'est pas compté, par contre si la note est supérieur à 10 on prend les points au dessus de 10 et on les multiplies par 3 en tant que point bonus, par exemple si on a 14 en eps on fait 4 x 3 et les points vont dans la moyenne général. Ça fait une semaine que je suis dessus, j ai tout essayé avec les moyennes.SI mais à chaque fois soit quand il y'a un 0 soit la formule bug soit ça ne marche pas, quelqu'un pourrait il m'aider si il vout plait ?

Bonsoir,

Je pense que tu pourrais partir sur quelque chose comme cela

=SI(B5<10;MOYENNE(B2;B3;B4;B6);MOYENNE(B2;B3;B4;B6)+SI(B5=20;10*C5;DROITE(B5;1)*C5))

Mais il y aura forcément un soucis avec le coeff multiplicateur ou encore le nombre à virgule

2moyenne.xlsx (9.16 Ko)

. Dans le fichier que je t'ai joins, tu as l'exemple concret.

Bonne soirée,

merci beaucoup, ça m aide déjà pas mal :)

Pas de soucis, n'oublie pas de mettre le sujet en résolu !

Bonne soirée,

Rechercher des sujets similaires à "pouvoir moyenne"