Arrondi de prix au dixième

Bonjour,

Je dois effectuer des tarifs dans lesquels j'applique des prix psychologiques.

les prix inférieurs à 15€ doivent se terminer par 0.09

les prix compris entre 15 et 100€ se terminent par 0.05

les prix compris entre 100 et 200€ se terminent par 0.50

et les prix supérieurs à 200 n'ont pas de décimal.

Auriez vous une formule qui pourrait m'aider, pcq ce n'est pas des petits tarif (env. 4000 prix différents)

Merci pour vos réponses

Bonjour lolo7134

Si je vous ai bien compris, la formule pourrait être :

=SI(A1<15;(ARRONDI(A1;1)-0,1)+0,09;SI(ET(A1>=15;A1<=100);(ARRONDI(A1;1)-0,1)+0,05;SI(ET(A1>=100;A1<200);ARRONDI(A1-1)+0,5;ENT(ARRONDI(A1)))))

Bonjour le Fil

Peut-être :

=SI(A1<15;ARRONDI(A1;1)-0,01;SI(ET(A1>=15;A1<100);ARRONDI(A1;1)-0,05;SI(ET(A1>=100;A1<200);ARRONDI(A1-0,5;0)+0,5;ARRONDI(A1;0))))

Bonjour et merci pour vos reponses.

Malheureusement, j'ai tester vos formules, et cela ne fonctionne pas. J'ai un message d'erreur a chaque fois.

Tu as probablement mal recopié la formule ....

5arrondi.ods (16.81 Ko)

Bonjour Patrice33740,

J'ai refait des tests, et cela fonctionne quand je retape la formule en entier. Etant donné le longueur de la formule j'avais fait un copier coller.

Je ne suis pas experte en Excel, est-ce normal qu'avec un copier/coller cela ne fonctionne pas?

C'est une formule que vais devoir utiliser pas mal de fois donc cela m'aurait intéressé de ne pas devoir la recopier à chaque tarif.

Merci,

Re,

Je ne suis pas experte en Excel, est-ce normal qu'avec un copier/coller cela ne fonctionne pas?

Sélectionnes la cellule qui contient la formule / copier / sélectionnes la destination / coller : ça devrait fonctionner

ok, merci pour l'info et la réactivité. Je vais tester cela.

Rechercher des sujets similaires à "arrondi prix dixieme"