Une autre formule pour supprimer les doublons d’une liste

Salut tous le monde

C’est une formule matricielle (ou par incrémentation) pour gérer les doublons (comme la fonction native " UNIQUE ") que j’ai écrit moi-même il y a quelques mois (je ne sais pas s’il existe déjà !?) et j ai voulu la partager comme même :(

La formule est appliquer directement n importe ou, il suffit de changer le range de la liste, ici par exemple A2:A19 , et le -1 par autre nombre pour choisir d ou commence la recherche

=SIERREUR(INDEX(A2:A19;PETITE.VALEUR(SIERREUR(EQUIV(LIGNE(A2:A19)-1;EQUIV(A2:A19;A2:A19;0);0);"Z");LIGNE(A2:A19)-1));"")

ice screenshot 20210925 190120

Ou l autre qui nécessite qu’on calcule on veut appliquer la formule par changer cette partie : LIGNE()-1

=SIERREUR(INDEX(A2:A19;PETITE.VALEUR(SIERREUR(EQUIV(LIGNE()-1;EQUIV(A2:A19;A2:A19;0);0);"Z");LIGNE()-1));"")

Crdlmt.

Merci AMIR pour ce partage

Rechercher des sujets similaires à "formule supprimer doublons liste"