Problème résultat sur une formule. Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Y
Yann69
Membre habitué
Membre habitué
Messages : 106
Inscrit le : 31 octobre 2015
Version d'Excel : 2016

Message par Yann69 » 31 octobre 2015, 10:18

Bonjour à tous,

Avant tout, je précise que je suis complètement débutant dans le domaine. Ça fait que quelques jours que je débute sous Excel et j'en apprends tous les jours. Sauf que voilà, là, je bloque totalement sur le résultat que me donne ma formule :(

Explications :

Je voudrait dans un planning déjà fait récupérer les dimanches travaillés dans le mois et en faire un total (en nombre de vacations). Pour se faire, ma formule va chercher les colonnes :

B1:B42 (qui sont des codes pour dire si la ligne est sem, dim ou férié).
K10:K42 (qui est une colonne qui calcule le total d'heures effectuées par ligne et est au format heure).

Voici ma formule pour compter les dimanches travaillés :

=SOMMEPROD(($B$10:$B$42="dim")*($K$10:$K$42))

Mon soucis est que le résultat que ça me donne est un chiffre et une virgule oO
Par exemple, pour trois dimanches travaillés dans le même mois, ça me donne en résultat : 1,364583333 au lieu de 3

Bref, je ne sais pas ou se trouve mon erreur :(

Pourriez-vous m'aider svp dans la correction de cette formule. Merci par avance ;)
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 15'136
Appréciations reçues : 495
Inscrit le : 27 août 2012
Version d'Excel : O365 32 bits

Message par Jean-Eric » 31 octobre 2015, 10:36

Bonjour,
Essaie ainsi :
=SOMMEPROD(($B$10:$B$42="dim")*($K$10:$K$42>0))
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
Y
Yann69
Membre habitué
Membre habitué
Messages : 106
Inscrit le : 31 octobre 2015
Version d'Excel : 2016

Message par Yann69 » 31 octobre 2015, 10:42

Bonjour Jean-Eric,

Merci pour la correction, ça a marché en partie. J'aimerais comprendre à quoi correspond ce 0 stp afin que je dormes moins bête ce soir. Pourrais-tu m'expliquer ?

J'ai un autre soucis dans cette même formule. Il me compte bien les dimanches mais ne prend pas en compte les dimanches "fériés" du mois. Et malheureusement, il peut y en avoir comme un demain ou je travaille.

Aurais-tu une solution stp ?
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'670
Appréciations reçues : 24
Inscrit le : 14 novembre 2012
Version d'Excel : 2016 FR

Message par R@chid » 31 octobre 2015, 14:37

Bonjour @ tous,
quand un dimanche est travaillé alors on va surement taper le nombre d'heure dans la colonne K alors automatiquement la valeur est supérieure à 0.
Sinon un fichier exemple sera plus parlant pour résoudre ton 2ème soucis.

@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 15'136
Appréciations reçues : 495
Inscrit le : 27 août 2012
Version d'Excel : O365 32 bits

Message par Jean-Eric » 31 octobre 2015, 19:23

Re,
Bonsoir R@chid,

Pour le 1er. point, Rachid a répondu à la question.
Pour le point des fériés, et si tu as 3 critères (sem, dim et férié). La formule précédente peut-être modifiée ainsi :
=SOMMEPROD(($B$10:$B$42<>"sem")*($K$10:$K$42>0))
Le résultat prendra en compte les dim et férié.
Cdlt.
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
Y
Yann69
Membre habitué
Membre habitué
Messages : 106
Inscrit le : 31 octobre 2015
Version d'Excel : 2016

Message par Yann69 » 31 octobre 2015, 19:24

Bonsoir,

Désoler mais je n'avais pas reçu de notifications de réponses pour ton message Rachid.
Je poste demain la version essai que j'ai fait ;)

Bonne soirée
Yann

Jean-Eric a écrit :Re,
Bonsoir R@chid,

Pour le 1er. point, Rachid a répondu à la question.
Pour le point des fériés, et si tu as 3 critères (sem, dim et férié). La formule précédente peut-être modifiée ainsi :
=SOMMEPROD(($B$10:$B$42<>"sem")*($K$10:$K$42>0))
Le résultat prendra en compte les dim et férié.
Cdlt.
Re,

Désoler mais j'ai pas compris ta formule. Je l'ai mise dans la colonne qui calcul les dimanches à la place de la mienne :
=SOMMEPROD(($B$10:$B$42="dim")*($K$10:$K$42>0))
Mais il me compte tout et non pas que les dimanches et dimanches fériés.

Qu'est-ce que "<>" stp ?
Y
Yann69
Membre habitué
Membre habitué
Messages : 106
Inscrit le : 31 octobre 2015
Version d'Excel : 2016

Message par Yann69 » 31 octobre 2015, 19:50

Voilà le fichier demandé. Merci par avance pour votre aide.
J'ai arrangé la formule car c'était "se" et non "sem" mais il prend quand même les autres jours fériés qui ne sont pas des dimanches.
A partager.xlsm
(37.72 Kio) Téléchargé 28 fois
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'670
Appréciations reçues : 24
Inscrit le : 14 novembre 2012
Version d'Excel : 2016 FR

Message par R@chid » 1 novembre 2015, 00:11

Bonsoir @ tous,
la colonne B est superfétatoire, pour les dimanches tu peux faire tout simplement :
=SOMMEPROD((JOURSEM($C$10:$C$42)=1)*($K$10:$K$42>0)*(NB.SI(Fer;$C$10:$C$42)=0))


@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
Y
Yann69
Membre habitué
Membre habitué
Messages : 106
Inscrit le : 31 octobre 2015
Version d'Excel : 2016

Message par Yann69 » 1 novembre 2015, 07:38

Bonjour Rachid,

Ta formule ne fonctionne pas. Elle ne prend pas les dimanches "non" fériés.
Pour la colonne B, je me doutais qu'elle était superflue mais j'ai repris le travail d'un autre planning trouvé sur la toile (ici même je crois) pour faire le mien puisque je n'y connaissais pas grand chose.

Du coup, il faudrait que je me mettre dedans pour supprimer cette colonne B et tout rediriger sur la colonne C ce qui ne sera pas évident à mon niveau.
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'670
Appréciations reçues : 24
Inscrit le : 14 novembre 2012
Version d'Excel : 2016 FR

Message par R@chid » 1 novembre 2015, 11:09

Bonjour,
je comprends pas ta question, j'ai calculé le nombre de dimanche avec colonne K <> "" en excluant les dimanches fériés.
pourrais-tu être un peu plus clair sur ta demande, en joignant un fichier avec des données dans toutes les colonnes pour que l'on puisse bien t'aider ?
"Donnez moi un point d'appui et je soulèverai le monde"
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message