Valeur plafonnée avec formule condition Si Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
Mariedk
Nouveau venu
Nouveau venu
Messages : 7
Inscrit le : 15 mars 2011
Version d'Excel : 2007 FR

Message par Mariedk » 15 mars 2011, 23:26

PB formule FDP.xls
fichier créé avec Excel 2007 mais enregistré au format 2003
(90.5 Kio) Téléchargé 64 fois
Bonjour,

J'ai besoin d'aide pour une formule utilisant la condition Si. La valeur doit être plafonnée à un pourcentage d'une autre cellule.

Je joins un petit fichier avec le détail de ce que je cherche à obtenir, ce que j'ai pensé pouvoir convenir et la formule qui en découle. Or, si les calculs s'effectuent correctement, le plafonnement n'est pas appliqué.

De plus, le taux s'affiche même quand il n'y a pas d'heures supplémentaires.

Merci par avance de toute l'aide que vous pourrez m'apporter.

Bonne fin de soirée.

Mariedk
Modifié en dernier par Mariedk le 18 mars 2011, 14:53, modifié 2 fois.
Cela prend moins de temps de faire quelque chose correctement, que d'expliquer pourquoi on l'a mal fait (Longfellow, Henry Wadsworth)
Avatar du membre
Nad
Passionné d'Excel
Passionné d'Excel
Messages : 4'861
Appréciation reçue : 1
Inscrit le : 16 mars 2008
Version d'Excel : 2003 FR - 2007 FR

Message par Nad » 16 mars 2011, 00:54

Bonsoir

D'après mes souvenirs sur les allègements de cotisations sur heures supplémentaires

Le taux en C27 :
=SI(SOMME(E26;E33;E34)/D8<21.5%;SOMME(E26;E33;E34)/D8;21.5%)
Le montant en E27 :
=SI(B27*C27>(E10+E12+E13);-(E10+E12+E13);-B27*C27)
Amicalement
Nad
Avatar du membre
Mariedk
Nouveau venu
Nouveau venu
Messages : 7
Inscrit le : 15 mars 2011
Version d'Excel : 2007 FR

Message par Mariedk » 16 mars 2011, 17:08

Bonjour Nad,

Je te remercie pour ta réponse rapide mais malheureusement, ça ne fonctionne pas.

J'ai entré tes formules tel quel :

1) C27 =SI(SOMME(E26;E33;E34)/D8<21.5%;SOMME(E26;E33;E34)/D8;21.5%)

- J'ai une erreur sur le premier 21.5%
- J'ai pensé que c'est parce que tu as oublié d'indiquer à quelle valeur il fallait appliquer ce taux alors j'ai corrigé par D8*21.5%
- J'ai toujours une erreur sur 21.5% alors j'ai transformé en D8*0.215 et là je n'ai plus d'erreur sur ce premier 21.5% de ta formule.
- J'ai une erreur sur le 2è 21.5% de ta formule, je fais la même modif et je n'ai plus d'erreur

Ta formule est maintenant devenue
=SI(SOMME(E26;E33;E34)/D8<D8*0,215;SOMME(E26;E33;E34)/D8;D8*0,215)

Les calculs sont bons mais le montant n'est pas plafonné puisque j'obtiens 30.01% en C27 au lieu des 21.5% maxi

2) D27 =SI(B27*C27>(E10+E12+E13);-(E10+E12+E13);-B27*C27)

Là, je n'ai pas compris pourquoi tu utilises les cellules E10, E12 & E13 et pourquoi tu ne divises plus par le salaire brut.

Merci d'avance pour ton aide.

Mariedk
Cela prend moins de temps de faire quelque chose correctement, que d'expliquer pourquoi on l'a mal fait (Longfellow, Henry Wadsworth)
Avatar du membre
Nad
Passionné d'Excel
Passionné d'Excel
Messages : 4'861
Appréciation reçue : 1
Inscrit le : 16 mars 2008
Version d'Excel : 2003 FR - 2007 FR

Message par Nad » 16 mars 2011, 17:58

Mariedk a écrit : 1) C27 =SI(SOMME(E26;E33;E34)/D8<21.5%;SOMME(E26;E33;E34)/D8;21.5%)
- J'ai une erreur sur le premier 21.5%
Remplace le point par une virgule

Mariedk a écrit :- J'ai pensé que c'est parce que tu as oublié d'indiquer à quelle valeur il fallait appliquer ce taux alors j'ai corrigé par D8*21.5%
Non, le taux = Total Charges/Salaire Brut - Soit
=SOMME(E26;E33;E34)/D8
Pour la limite de 21.50
=SI(SOMME(E26;E33;E34)/D8<21,5%;SOMME(E26;E33;E34)/D8;21,5%)
Mariedk a écrit : 2) D27 =SI(B27*C27>(E10+E12+E13);-(E10+E12+E13);-B27*C27)

Là, je n'ai pas compris pourquoi tu utilises les cellules E10, E12 & E13 et pourquoi tu ne divises plus par le salaire brut.
Parce que :
Capture.JPG
Capture.JPG (31.66 Kio) Vu 1481 fois
Amicalement
Nad
Avatar du membre
Mariedk
Nouveau venu
Nouveau venu
Messages : 7
Inscrit le : 15 mars 2011
Version d'Excel : 2007 FR

Message par Mariedk » 16 mars 2011, 22:04

Nad a écrit :Mariedk a écrit:
1) C27 =SI(SOMME(E26;E33;E34)/D8<21.5%;SOMME(E26;E33;E34)/D8;21.5%)
- J'ai une erreur sur le premier 21.5%

Remplace le point par une virgule


Mariedk a écrit:
- J'ai pensé que c'est parce que tu as oublié d'indiquer à quelle valeur il fallait appliquer ce taux alors j'ai corrigé par D8*21.5%

Non, le taux = Total Charges/Salaire Brut - Soit
CODE: TOUT SÉLECTIONNER
=SOMME(E26;E33;E34)/D8


Pour la limite de 21.50
CODE: TOUT SÉLECTIONNER
=SI(SOMME(E26;E33;E34)/D8<21,5%;SOMME(E26;E33;E34)/D8;21,5%)
Ok, c'est fait et ça marche !

J'ai vérifié les calculs à la calculatrice et comme le taux est TOUJOURS supérieur à 21,5%, quelque soit le nombre d'heures supplémentaires, ta formule plafonne bien le taux à 21,5%. :)

La seule question que je me pose maintenant, c'est pourquoi ne pas tout simplement indiquer un taux de 21,5% plutôt que toute cette formule puisque le taux est toujours tel qu'il doit être plafonné... :roll:

Si tu as une réponse, je suis preneuse (pour ma culture personnelle), sinon, ce n'est pas très grave, l'important c'est que ça marche !

En tout cas, merci beaucoup pour ton aide précieuse. :D

Amicalement,

Mariedk
Cela prend moins de temps de faire quelque chose correctement, que d'expliquer pourquoi on l'a mal fait (Longfellow, Henry Wadsworth)
Avatar du membre
Nad
Passionné d'Excel
Passionné d'Excel
Messages : 4'861
Appréciation reçue : 1
Inscrit le : 16 mars 2008
Version d'Excel : 2003 FR - 2007 FR

Message par Nad » 16 mars 2011, 23:45

Mariedk a écrit :J'ai vérifié les calculs à la calculatrice et comme le taux est TOUJOURS supérieur à 21,5%, quelque soit le nombre d'heures supplémentaires, ta formule plafonne bien le taux à 21,5%. :)

La seule question que je me pose maintenant, c'est pourquoi ne pas tout simplement indiquer un taux de 21,5% plutôt que toute cette formule puisque le taux est toujours tel qu'il doit être plafonné... :roll:

Si tu as une réponse, je suis preneuse
Oui, j'ai la réponse - Je n'ai pas enlevé la mutuelle (E21) !!! La bonne formule :
=SI((SOMME(E26;E33;E34)-E21)/D8<21.5%;(SOMME(E26;E33;E34)-E21)/D8;21.5%)
Amicalement
Nad
Avatar du membre
Mariedk
Nouveau venu
Nouveau venu
Messages : 7
Inscrit le : 15 mars 2011
Version d'Excel : 2007 FR

Message par Mariedk » 18 mars 2011, 14:54

Nad a écrit :Oui, j'ai la réponse - Je n'ai pas enlevé la mutuelle (E21) !!! La bonne formule :

CODE: TOUT SÉLECTIONNER
=SI((SOMME(E26;E33;E34)-E21)/D8<21.5%;(SOMME(E26;E33;E34)-E21)/D8;21.5%)
Bonsoir Nad,

Tout d'abord, te remercie beaucoup pour ton aide car je ne crois pas que j'aurais pu m'en sortir seule.

J'ai fait la modif dans la formule et en faisant des tests, je m'aperçois que même en mettant une énormité comme 200 HS, on n'arrive que péniblement à un taux de 18.47 % !!! De nouveau, pourquoi plafonner si on ne risque jamais d'atteindre le plafond ? Je pense qu'il doit encore y avoir un problème quelque part... mais où ? :roll:

J'ai oublié de te préciser que la mutuelle est prise entièrement en charge par l'entreprise. Il n'y a aucune retenu sur ma fdp, l'employeur la prend entièrement à sa charge.

Sur le fichier que j'avais mis dans mon post, la mutuelle apparaissant dans la même colonne que les cotisations salariales mais c'était une erreur. :oops:

Je remets la formule précédente ? Mais dans ce cas, on reste toujours en-dessous de 21.5% ce qui me fait donc reposer ma question de tout à l'heure. Pourquoi ça ne dépasse jamais les 21.5% alors qu'on prévoit un plafonnement à 21.5 % ? :roll:

Désolée de t'embêter de nouveau avec ça... :oops:

Merci d'avance pour ton aide.

Mariedk
Cela prend moins de temps de faire quelque chose correctement, que d'expliquer pourquoi on l'a mal fait (Longfellow, Henry Wadsworth)
Avatar du membre
Mariedk
Nouveau venu
Nouveau venu
Messages : 7
Inscrit le : 15 mars 2011
Version d'Excel : 2007 FR

Message par Mariedk » 21 mars 2011, 22:33

Quelqu'un aurait-il une réponse svp ?
Cela prend moins de temps de faire quelque chose correctement, que d'expliquer pourquoi on l'a mal fait (Longfellow, Henry Wadsworth)
t
thibo
Passionné d'Excel
Passionné d'Excel
Messages : 3'091
Inscrit le : 3 mai 2007
Version d'Excel : Excel 2003 + 2007

Message par thibo » 22 mars 2011, 03:20

Bonjour,

Avec un nbre d'HS de 10, Mutuelle : 0 part salariale et 130.30 part employeur, la formule :

(SOMME(E26;E33;E34)-E21)/D8

E21 étant égal à 0

me donne 0.220759

le plafonnement s'effectue bien

Vérifie si tu n'as pas conservé le montant de la mutuelle (devenue patronale) dans ton calcul.

@+
Avatar du membre
Nad
Passionné d'Excel
Passionné d'Excel
Messages : 4'861
Appréciation reçue : 1
Inscrit le : 16 mars 2008
Version d'Excel : 2003 FR - 2007 FR

Message par Nad » 22 mars 2011, 09:40

Bonjour

Il y a également la réduction Fillon qui est une réduction patronale et non salariale.

Je t'ai préparé une nouvelle fiche de paye :
Formules FDP.xls
(113.5 Kio) Téléchargé 83 fois
Amicalement
Nad
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message