SOMMEPROD sur une plage de critères

Bonjour à tous,

Je souhaite extraire d'un tableau le total des valeurs en fonction d'une plage de critères.

Dans mon exemple, j'ai un tableau d'écritures comptables (nommé data20)

J'utilise SOMMEPROD pour, par exemple faire le total au crédit du compte 101000 de telle date à telle date.

Jusque là, pas de soucis.

=SOMMEPROD((data20[credit])*(data20[date]>=$D$9)*(data20[date]<=$E$9)*(data20[compte]=$C11))

Est-ce que vous avez une solution si je veux le total de tous les comptes inscrits dans la plage C11:C13 ?

Sans être obligé de faire un truc du genre :

=SOMMEPROD((data20[credit])*(data20[date]>=$D$9)*(data20[date]<=$E$9)*(data20[compte]=$C11))+SOMMEPROD((data20[credit])*(data20[date]>=$D$9)*(data20[date]<=$E$9)*(data20[compte]=$C12))+SOMMEPROD((data20[credit])*(data20[date]>=$D$9)*(data20[date]<=$E$9)*(data20[compte]=$C13))

En sachant que la fonction SOMME() ne me convient pas pour ce que je veux faire ...

J'ai bêtement essayé ça :

=SOMMEPROD((data20[credit])*(data20[date]>=$D$9)*(data20[date]<=$E$9)*(data20[compte]=$C11:$C13))

Mais ça marche pas ...

Merci d'avance

Alain.

Bonjour à tous,

Tu peux simplifier ta formule :

=[color=#FF0000]SOMMEPROD((data20[credit])*(data20[date]>=$D$9)*(data20[date]<=$E$9)[/color]*(data20[compte]=$C11))+[color=#FF0000]SOMMEPROD((data20[credit])*(data20[date]>=$D$9)*(data20[date]<=$E$9)[/color]*(data20[compte]=$C12))+[color=#FF0000]SOMMEPROD((data20[credit])*(data20[date]>=$D$9)*(data20[date]<=$E$9)[/color]*(data20[compte]=$C13))

==>

=SOMMEPROD((data20[credit])*(data20[date]>=$D$9)*(data20[date]<=$E$9)*((data20[compte]=$C11)+(data20[compte]=$C12)+(data20[compte]=$C13)))

Crdlmt

Bonjour à vous deux,

Peut être en matricielle CTRL+SHIFT+ENTREE

=SOMMEPROD((data20[credit])*(data20[date]>=$D$9)*(data20[date]<=$E$9)*(data20[compte]=$O6:$O27))

Cdt

Une autre solution avec la suppression des comptes en doublon avec power query et la fonction somme.

Cdt

Merci à vous deux,

@DjiDji5959430 :

effectivement, ça raccourci un peu

@ddetp88 :

la formule en matricielle avec (data20[compte]=$O6:$O27) ne marche pas : reponse N/A#

En fait ce que voudrait faire, c'est pouvoir modifier la programmation de mon tableau sans être obligé d'aller fouiller dans les formules.

Je souhaite juste changer les numeros de comptes dont je veux le total en fonction du critère de date sans que l'opérateur mette les main dans le camboui ...

je sais pas si j'ai été assez clair là

Bonjour à tous

Une solution via PowerQuery

Actualiser via Données, Actualiser tout

5somme-comptes.xlsx (22.93 Ko)
@ddetp88 :
la formule en matricielle avec (data20[compte]=$O6:$O27) ne marche pas : reponse N/A#

Regarde en F30 j'ai mis la formule en place

Ainsi dans le fichier tu as la solution avec PowerQuery et avec la formule

Cdt

Rechercher des sujets similaires à "sommeprod plage criteres"