Somme prod

Y compris Power BI, Power Query et toute autre question en lien avec Excel
z
zeldanat28
Membre habitué
Membre habitué
Messages : 102
Inscrit le : 8 avril 2012
Version d'Excel : 2016

Message par zeldanat28 » 8 mai 2019, 15:34

Dans le tableau joint, à l'onglet rouge GLOBAL OPERATION je souhaite mettre, par entité, le montant total des subventions affectées à l'entité indiquée en colonne A.
J'ai donc créé une colonne pour chaque type de subvention, qui ira chercher les informations dans chaque onglet (1 type de subvention = 1 onglet)

J'ai mis la formule, pour la colonne FRAFU DEAL, =SOMMEPROD((OP_FRAFU)=A2)*(Bdgt_FRAFU)

Mais çà me renvoit une valeur

SOMMEPROD est-il approprié pour ce que je cherche à obtenir ?
Suivi appels de fonds.xlsx
(305.75 Kio) Téléchargé 7 fois
Avatar du membre
DjiDji59430
Membre impliqué
Membre impliqué
Messages : 2'103
Appréciations reçues : 69
Inscrit le : 18 avril 2015
Version d'Excel : 2019 FR

Message par DjiDji59430 » 8 mai 2019, 15:49

Bonjour à tous,

=SOMMEPROD((OP_FRAFU)=A2)*(Bdgt_FRAFU)
ta formule est fausse, mauvaise place des ()


=SOMMEPROD((OP_FRAFU=A2)*(Bdgt_FRAFU))


Crdlmt
z
zeldanat28
Membre habitué
Membre habitué
Messages : 102
Inscrit le : 8 avril 2012
Version d'Excel : 2016

Message par zeldanat28 » 8 mai 2019, 18:33

merci effectivement c'est beaucoup mieux, je suis vraiment une bique !!

Je veux à présent récapituler, opération par opération, le montant qui a été payé année par année.
Ainsi j'ai commencé à le faire en colonne V : pour chaque dossier, je souhaite savoir qu'est-ce qui a été payé à fin 2018.
J'ai mis la formule suivante :
=SOMMEPROD((OP_ST_JO=A7)*(DatePmt_ST_JOSEPH<>"")*(DatePmt_ST_JOSEPH<>"en attente")*(ANNEE(DatePmt_ST_JOSEPH)=ANNEE(M5))*(ESTNUM(MtntPaye_ST_JOSEPH));MtntPaye_ST_JOSEPH)

En V39, je devrais avoir comme résultat : 146 111,10
Mais j'ai zéro ...

Et j'ai #VALEUR! en V4
Suivi appels de fonds.xlsx
(316.2 Kio) Téléchargé 4 fois
Avatar du membre
DjiDji59430
Membre impliqué
Membre impliqué
Messages : 2'103
Appréciations reçues : 69
Inscrit le : 18 avril 2015
Version d'Excel : 2019 FR

Message par DjiDji59430 » 8 mai 2019, 19:40

re
=SOMMEPROD((OP_ST_JO=A7)*(DatePmt_ST_JOSEPH<>"")*(DatePmt_ST_JOSEPH<>"en attente")*(ANNEE(DatePmt_ST_JOSEPH)=ANNEE(M5))*(ESTNUM(MtntPaye_ST_JOSEPH));MtntPaye_ST_JOSEPH)

(OP_ST_JO=A7) oui

(DatePmt_ST_JOSEPH<>"")
(DatePmt_ST_JOSEPH<>"en attente")
(ESTNUM(MtntPaye_ST_JOSEPH)
pas de données utilisables, il n'y a rien dans les cellules correspondantes a A5, A9, 13

(ANNEE(DatePmt_ST_JOSEPH)=$m$1 avec des $ sinon ça s'incrémente

pour utiliser sommeprod() comme tu veux le faire, il ne faut pas de cellules vides en colonne A 'st joseph), c'est obligatoire
Suivi appels de fonds2.xlsx
(318.57 Kio) Téléchargé 2 fois

Crdlmt
z
zeldanat28
Membre habitué
Membre habitué
Messages : 102
Inscrit le : 8 avril 2012
Version d'Excel : 2016

Message par zeldanat28 » 10 mai 2019, 08:08

initialement sur chaque ligne j'avais le nom de l'opération en face de chaque date et montant mais si je fais çà, ça fausse le calcul de la colonne TOTAL SUBVENTIONS car çà additionnait les pourcentages calculés dans les colonnes BUDGET de chaque onglet
Du coup, afin de pouvoir rajouter quelque chose dans les cellules vides, j'ai créé une nouvelle colonne où je met les pourcentages mais toute ma colonne X est à 0 (cf tableau joint)
Suivi appels de fonds.xlsx
(315.33 Kio) Téléchargé 2 fois
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 418
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 10 mai 2019, 08:28

Bonjour,

Ci-joint ... la petite correction ... :wink:

En espèrant que cela t'aide
Suivi appels de fonds.xlsx
(328.28 Kio) Téléchargé 5 fois
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
z
zeldanat28
Membre habitué
Membre habitué
Messages : 102
Inscrit le : 8 avril 2012
Version d'Excel : 2016

Message par zeldanat28 » 13 mai 2019, 10:00

merci mais je ne vois pas du tout ce qui a changé entre les 2 formules ?
d'ailleurs est-ce cette formule que tu as modifié ?
=SOMMEPROD((OP_ST_JO=A3)*(DatePmt_ST_JOSEPH<>"")*(DatePmt_ST_JOSEPH<>"en attente")*(ANNEE(DatePmt_ST_JOSEPH)=$O$1)*(ESTNUM(MtntPaye_ST_JOSEPH));MtntPaye_ST_JOSEPH)

ou une autre ?

car elle est similaire à celle qu'il y avait et qui renvoyait 0
SOMMEPROD((OP_ST_JO=A3)*(DatePmt_ST_JOSEPH<>"")*(DatePmt_ST_JOSEPH<>"en attente")*(ANNEE(DatePmt_ST_JOSEPH)=$O$1)*(ESTNUM(MtntPaye_ST_JOSEPH));MtntPaye_ST_JOSEPH)

c'est pour je comprenne bien la solution au problème
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 418
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 13 mai 2019, 10:06

Bonjour,

Content que tu aies la solution à ton problème ... :wink:

Dans ta cellule O1 ... tu as déjà l'année ...

Donc il ne faut pas utiliser :
ANNEE($O$1)
mais simplement $O$1 ...
Modifié en dernier par James007 le 14 mai 2019, 07:41, modifié 1 fois.
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
z
zeldanat28
Membre habitué
Membre habitué
Messages : 102
Inscrit le : 8 avril 2012
Version d'Excel : 2016

Message par zeldanat28 » 14 mai 2019, 07:16

j'ai un autre souci : j'ai mis les formules dans chaque colonne et il y a des cellules où le résultat qui sort est 0 alors qu'il devrait y avoir un montant (cellules surlignées en rouge)
Suivi appels de fonds.xlsx
(318.16 Kio) Téléchargé 2 fois
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 418
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 14 mai 2019, 07:51

Bonjour,

De rien ...

J'espère que tu as compris la différence entre ta formule ... et la formule corrigée ...

Pour ta nouvelle question ... je vais également t'envoyer la correction ...
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message