Extraction conditionnelle un peu compliquée

Y compris Power BI, Power Query et toute autre question en lien avec Excel
A
Anthax
Jeune membre
Jeune membre
Messages : 45
Inscrit le : 1 juin 2009
Version d'Excel : 2007 EN

Message par Anthax » 1 juin 2009, 20:38

Ok.
Je ne sais pas trop par où commencer...
"Bonjour" est un bon début !

J'ai cet énorme fichier Excel qui regroupe toutes les localisations d'une trentaine de chevreuils au cours des 2 dernières années. Ces localisations ont été enregistrées par leur collier GPS ; le hic, c'est que le collier a parfois enregistré des localisation toutes les heures, puis sur d'autres périodes toutes les 2 heures, ou toutes les 4 heures, 6 heures... ou toute les 1/2 heures !!!
A présent, pour mes analyses, j'ai besoin de recréer un fichier Excel avec une localisation UNIQUEMENT toutes les 2 heures, et UNIQUEMENT les heures paires...

Du coup, quand j'ai un point à 0:00 puis à 0:30 - 1:00 - 1:30 - 2:00 - 3:00 - 4:00 il me faut extraire uniquement 0:00 - 2:00 - 4:00.

Voir mon fichier d'exemple : https://www.excel-pratique.com/~files/do ... xemple.xls

La colonne G (Cons_Time_V) me donne l'intervalle de temps (en heures) entre deux localisations successives.
Ensuite, j'ai créé un tableau de référence appelé "two" (feuille "Ref") qui me sert à déterminer si l'heure d'une localisation donnée rentre dans le planning qui m'intéresse (donc 0:00 - 2:00 - 4:00, etc.) C'est l'information que l'on retrouve dans la colonne H (2_hours).

Et ensuite, je cale... :?:

Comment faire pour avoir une dernière colonne dans laquelle j'aurais des 1 à chaque localisation pour laquelle il existe une autre localisation prise 2h plus tard ?

Toute aide sera précieuse... Merci de votre temps !
N
Nad-Dan
Passionné d'Excel
Passionné d'Excel
Messages : 7'305
Inscrit le : 27 avril 2007
Version d'Excel : 2003 FR-2007 FR-MAC 2004 FR

Message par Nad-Dan » 1 juin 2009, 20:58

Bonsoir et bienvenue

Pour la colonne 2_hours, tu n'as pas besoin d'une autre feuille. La formule :
=SI(EST.PAIR(D2);1;0)
fait la même chose.
Comment faire pour avoir une dernière colonne dans laquelle j'aurais des 1 à chaque localisation pour laquelle il existe une autre localisation prise 2h plus tard ?
J'y réfléchis.

A te relire
Amicalement
Nad
A
Anthax
Jeune membre
Jeune membre
Messages : 45
Inscrit le : 1 juin 2009
Version d'Excel : 2007 EN

Message par Anthax » 1 juin 2009, 21:06

Nad-Dan a écrit : Pour la colonne 2_hours, tu n'as pas besoin d'une autre feuille. La formule :
=SI(EST.PAIR(D2);1;0)
Oui, c'est vrai que ça marche bien dans ce cas... Mais pour la suite de mon travail, je dois aussi faire la même chose pour les localisations toutes les 4 heures, puis localisation toutes les heures ! D'où mon tableau de référence...

Nad-Dan a écrit :
Comment faire pour avoir une dernière colonne dans laquelle j'aurais des 1 à chaque localisation pour laquelle il existe une autre localisation prise 2h plus tard ?
J'y réfléchis.
Wahou ! Je suis surpris que tu n'aies pas déjà des précisions à me demander... Ai-je donc été assez clair ? Tu as compris ce dont j'ai besoin ! Super ! et merci Nad de te pencher avec moi là-dessus !
N
Nad-Dan
Passionné d'Excel
Passionné d'Excel
Messages : 7'305
Inscrit le : 27 avril 2007
Version d'Excel : 2003 FR-2007 FR-MAC 2004 FR

Message par Nad-Dan » 1 juin 2009, 21:57

Re

Est-ce qu'au changement de jour on à 0 ou bien on met 1 si la veille on a 22:00 et donc le jour d'après 00:00 ?

Nad
A
Anthax
Jeune membre
Jeune membre
Messages : 45
Inscrit le : 1 juin 2009
Version d'Excel : 2007 EN

Message par Anthax » 1 juin 2009, 22:07

Le changement de jour n'est pas important : c'est un critère arbitraire Humain en fait... Donc si on a une localisation à 22h00 puis une autre à Minuit, il faut garder celle de minuit aussi ! (donc 1 !)

De même si on a des localisations toutes les 4 heures jusqu'à minuit, puis qu'ensuite le planning du collier change à minuit pour prendre à nouveaux toutes les heures, il faut garder aussi celle de minuit !

Par exemple : (en gras, celle que je dois garder)
20:00
22:00
00:00
2e jour
04:00
08:00
12:00
16:00
20:00
00:00 3e jour
01:00
02:00
03:00
03:30
04:00
4:30
5:00
5:30
6:00
.
.
.
etc.
N
Nad-Dan
Passionné d'Excel
Passionné d'Excel
Messages : 7'305
Inscrit le : 27 avril 2007
Version d'Excel : 2003 FR-2007 FR-MAC 2004 FR

Message par Nad-Dan » 1 juin 2009, 22:16

J'y suis presque ; il me manque le 1 pour les 0:00

Nad
A
Anthax
Jeune membre
Jeune membre
Messages : 45
Inscrit le : 1 juin 2009
Version d'Excel : 2007 EN

Message par Anthax » 1 juin 2009, 22:17

Cool !

Moi, j'avance sur une piste, mais je ne suis pas sûr d'aboutir...
J'ai hâte que tu me montres ce que tu trouves !

Merci beaucoup !
N
Nad-Dan
Passionné d'Excel
Passionné d'Excel
Messages : 7'305
Inscrit le : 27 avril 2007
Version d'Excel : 2003 FR-2007 FR-MAC 2004 FR

Message par Nad-Dan » 1 juin 2009, 22:35

Je tourne en rond.

Voilà où j'en suis :

Fichier

Je n'arrive plus à réfléchir. Si quelqu'un pouvait aider ....

Nad
A
Anthax
Jeune membre
Jeune membre
Messages : 45
Inscrit le : 1 juin 2009
Version d'Excel : 2007 EN

Message par Anthax » 1 juin 2009, 22:52

Voilà ma piste...
On dirait que ça marche !

https://www.excel-pratique.com/~files/do ... ple_ok.xls

Mais alors pour expliquer le raisonnement... :?

Faut que je voie à présent pour les intervalles de 1h ou 4 heures...
N
Nad-Dan
Passionné d'Excel
Passionné d'Excel
Messages : 7'305
Inscrit le : 27 avril 2007
Version d'Excel : 2003 FR-2007 FR-MAC 2004 FR

Message par Nad-Dan » 1 juin 2009, 23:29

Ou je n'ai pas bien compris, ou alors c'est comme mon fichier : ça ne marche pas partout.

Je te renvoie ton fichier avec ce que je pense être des erreurs

Fichier

Nad
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message