Formule NB.SI ???

Bonjour à Tous , je pêche sur un programme Excel que je viens de crée , je vous explique :

J'ai créer un planning de congés , maladie etc etc de cette manière :

Un onglet par mois , janvier , février etc etc...

Un onglet Config , et c'est de la que je fais tout mes réglages automatiques . ( et c'est la que je veux ma formule dans le tableau )

la dessus j'ai un récapitulatif de l'année pour chaque employée pour les congés , maladie , récup etc....

Ma question est la suivante :

Quelle formule je dois mettre sachant que je veux comme résultat qu'il me trouve le nombre de ND ( congés non décomptés ) dans chaque feuille , par employée ( donc par ligne ) et dans cette ligne que le nombre de "ND" et ne pas me compter les MA , CP Etc etc ( maladie,congés )

je joins le fichier avec , merci en avance ...

Voici le mot de passe pour les feuilles protégées : lo@de%

7souhait-conges.xlsx (114.81 Ko)

Je UP la demande car j'ai trouver la FORMULE mais que pour Janvier , comment faire pour que ça me le calcule toute l'année de Janvier à Décembre ???

=SI(B11="";"";NB.SI(Janvier!F11:AJ11;"ND"))

Hello,

Tu peux faire comme ça dans la cellule K4 de ton onglet "config" :

=SI(B4="";"";NB.SI(Janvier!F11:AJ11;"ND")+NB.SI(Février!F11:AJ11;"ND"))

Tu fais ça jusque décembre.

A+

Hello,

Tu peux faire comme ça dans la cellule K4 de ton onglet "config" :

=SI(B4="";"";NB.SI(Janvier!F11:AJ11;"ND")+NB.SI(Février!F11:AJ11;"ND"))

Tu fais ça jusque décembre.

A+

Merci Rag02700 de t'avoir pencher sur ma question , ça marche plutôt pas mal .

Maintenant j'ai un autre soucis c'est que dans ma formule j'ai mis que si B4 est vide alors ne rien écrire en K4 DE MON ONGLET CONFIG sauf qu'il me met ####### #VALEUR

=SI(B4="";"";NB.SI(Janvier!F11:AJ11;"ND"))+NB.SI(Février!F11:AJ11;"ND")+(NB.SI(Mars!F11:AJ11;"ND"))+NB.SI(Avril!F11:AJ11;"ND")+(NB.SI(Mai!F11:AJ11;"ND"))+NB.SI(Juin!F11:AJ11;"ND")+NB.SI(Juillet!F11:AJ11;"ND")+NB.SI(Août!F11:AJ11;"ND")+(NB.SI(Septembre!F11:AJ11;"ND"))+NB.SI(Octobre!F11:AJ11;"ND")+(NB.SI(Novembre!F11:AJ11;"ND"))+NB.SI(Décembre!F11:AJ11;"ND")

Tu saurais pourquoi ?

Bonsoir @ tous,

en H4 :

=SOMMEPROD(NB.SI(INDIRECT($D$6:$D$17&"!F"&LIGNE(A11)&":AJ"&LIGNE(A11));H$3))

@ tirer vers le bas et vers la droite

@ + +

Hello atomic,

Erreur de syntaxe :

=SI(B4="";"";NB.SI(Janvier!F11:AJ11;"ND")+NB.SI(Février!F11:AJ11;"ND")+(NB.SI(Mars!F11:AJ11;"ND")+NB.SI(Avril!F11:AJ11;"ND")+(NB.SI(Mai!F11:AJ11;"ND")+NB.SI(Juin!F11:AJ11;"ND")+NB.SI(Juillet!F11:AJ11;"ND")+NB.SI(Août!F11:AJ11;"ND")+(NB.SI(Septembre!F11:AJ11;"ND")+NB.SI(Octobre!F11:AJ11;"ND")+(NB.SI(Novembre!F11:AJ11;"ND")+NB.SI(Décembre!F11:AJ11;"ND"))))))

Si ton B4 est vide alors vide maintenant

a+

Hello atomic,

Erreur de syntaxe :

=SI(B4="";"";NB.SI(Janvier!F11:AJ11;"ND")+NB.SI(Février!F11:AJ11;"ND")+(NB.SI(Mars!F11:AJ11;"ND")+NB.SI(Avril!F11:AJ11;"ND")+(NB.SI(Mai!F11:AJ11;"ND")+NB.SI(Juin!F11:AJ11;"ND")+NB.SI(Juillet!F11:AJ11;"ND")+NB.SI(Août!F11:AJ11;"ND")+(NB.SI(Septembre!F11:AJ11;"ND")+NB.SI(Octobre!F11:AJ11;"ND")+(NB.SI(Novembre!F11:AJ11;"ND")+NB.SI(Décembre!F11:AJ11;"ND"))))))

Si ton B4 est vide alors vide maintenant

a+

Super , merci beaucoup , ça fonctionne à merveille .

Au plaisir

Pense à mettre résolu

A+

Re,

Bonsoir @ tous,

en H4 :

=SOMMEPROD(NB.SI(INDIRECT($D$6:$D$17&"!F"&LIGNE(A11)&":AJ"&LIGNE(A11));H$3))

@ tirer vers le bas et vers la droite

@ + +

Personne n'a testé cette belle formule.

Cordialement

Bonjour R@chid,

je viens de tester ta formule sur le fichier du demandeur :

4souhait-conges.xlsx (108.82 Ko)

je confirme que ça marche de façon impeccable !

et pas seulement pour ND : pour tous les autres aussi !


remarque : dans le fichier du demandeur, j'ai mis la formule de R@chid en H4 et je l'ai étirée vers le bas puis à droite, tout comme R@chid l'avait indiqué ; au début, j'ai cru qu'ça marchait pas car y'avait que des 0 ; mais c'est seulement car le demandeur n'a mis aucun exemple de données sur les feuilles de janvier à décembre ; aussi, j'ai ajouté quelques données sur la feuille janvier et sur la feuille décembre.

dhany

Bonjour,

merci cher dhany pour ce retour.

Cordialement

Oui mon petit programme fonctionne à merveille grâce à l'aide qu'on peut nous y apporter sur le forum , c'est vraiment appréciable , qui plus est une fois le coup de pouce , ça me permet de regarder les modifications et de comprendre et d'évoluer progressivement mon niveau sur Excel ... Merci les génies

Rechercher des sujets similaires à "formule"