NB.SI à plusieurs critères

Y compris Power BI, Power Query et toute autre question en lien avec Excel
k
krystof78
Nouveau venu
Nouveau venu
Messages : 7
Inscrit le : 6 mars 2007

Message par krystof78 » 6 mars 2007, 15:49

Bonjour,

J'ai un tableau où, en colonne, j'ai la date, le nombre de vente et à quel type de client ces ventes ont été faites, cela sur 3 ans.

Je cerche en fait à déterminer le nombre de ventes de chaque type de clients par année. Il me semble que, avec un NB.SI avec plusieurs critères (style : NB.SI(A1:B50; B1; C1>01/01/2004; C1<31/12/2004)), cela serait possible, mais je ne sais pas si c'est possible.

Pouvez-vous m'éclairer sur ce sujet, ou le moyen d'arriver à ce que je cherche à obtenir ?

Merci d'avance.

Christophe
A
Amadéus
Modérateur
Modérateur
Messages : 17'746
Appréciations reçues : 66
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 6 mars 2007, 16:37

Bonjour

On y arrive trés bien avec SOMMEPROD

Les dates en B2:B20, les montants en D2:D20

Les ventes 2004
=SOMMEPROD((ANNEE($B$2:$B$20)=2004)*($D$2:$D$20))
Exemple joint

Cordialement,

Amadéus

https://www.excel-pratique.com/~files/do ... Dates2.xls
k
krystof78
Nouveau venu
Nouveau venu
Messages : 7
Inscrit le : 6 mars 2007

Message par krystof78 » 6 mars 2007, 17:44

Merci beaucoup pour ces info, ça m'aide pour une partie des données.

Il reste cependant un point non résolu. En effet, vous trouvez bien avec cela les ventes 2004, 2005 et 2006, mais pas par type de client (une autre colonne avec le type et, disons, 3 types de clients différents)

Il me faudrait en effet, selon votre exemple :
- les ventes 2004, 2005 et 2006 du type de clients A, correspondant par exemple au client 1, 3 et 9.
- les ventes 2004, 2005 et 2006 du type de clients B, correspondant par exemple au client 2, 5, 6 et 8.
- les ventes 2004, 2005 et 2006 du type de clients C, correspondant par exemple au client 4, 7 et 10.

En tout cas, merci pour l'autre formule, ça m'aide pour autre chose... :)
A
Amadéus
Modérateur
Modérateur
Messages : 17'746
Appréciations reçues : 66
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 7 mars 2007, 00:02

Bonsoir

Pour calculer les Ventes 2005 du client 3
Si les dates sont en B2:B20,les clients en C2:C20 et les montants en E2:E20

=SOMMEPROD((ANNEE($B$2:$B$20)=2005)*($C$2:$C$20="Client3")*($E$2:$E$20))
=SOMMEPROD((1er Critère)*(2éme Critére)*(Champ à Sommer))

Pour additionner Client3 et Client4
=SOMMEPROD((ANNEE($B$2:$B$20)=2005)*(($C$2:$C$20="client3")+($C$2:$C$20="client4"))*($E$2:$E$20))
Exemple joint,

Cordialement,

Amadéus

https://www.excel-pratique.com/~files/do ... Dates2.xls
k
krystof78
Nouveau venu
Nouveau venu
Messages : 7
Inscrit le : 6 mars 2007

Message par krystof78 » 7 mars 2007, 09:34

Parfait, c'est exactement ce qu'il me fallait... Merci beaucoup... :)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message