Afficher des intervalles Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
A
AntoineBo
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 6 mars 2019
Version d'Excel : 2016 FR

Message par AntoineBo » 12 avril 2019, 12:21

Bonjour,

Je coince en ce moment avec mon impossibilité d'afficher des intervalles. Je m'explique:

Dans le fichier exemple que je mets en PJ, je souhaite faire apparaître le premier numéro de pièce d'une série de numéro qui se suivent ainsi que le dernier. Pour pouvoir extraire les intervalles. Exemple
Col 1 Col 2 Col 3
124 124 127
125 132 134
126 141 141 (ou rien)
127 145 146
132
133
134
141
145
146

Dans le fichier exemple vous trouverez une série de numéro de pièce extraite sous le format texte (que je n'arrive pas à transformer en nombre ou standard même en modifier les formats dans l'onglet prévu à cet effet, je suis obligé de double cliquer dans chaque cellule et d'appuyer sur entrée après avoir modifier le format, impossible de prendre le temps pour 1000 numéros ...) et le premier essai que j'ai réalisé avec ses ratés.

J'ai rajouté un grand nombre de numéro de pièce, les plages de cellules ne sont plus correctes.

Pouvez-vous m'aiguiller dans la bonne direction ?

Bien cordialement,
Intervalles.xlsx
(20.96 Kio) Téléchargé 4 fois
Avatar du membre
78chris
Passionné d'Excel
Passionné d'Excel
Messages : 4'298
Appréciations reçues : 317
Inscrit le : 9 juillet 2017
Version d'Excel : 2010 à 2019 + 365

Message par 78chris » 12 avril 2019, 12:28

Bonjour

A tester
=SI($B$2:$B$66=D2;MIN(($A$2:$A$66)*1);"")
Chris
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
Confucius
A
AntoineBo
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 6 mars 2019
Version d'Excel : 2016 FR

Message par AntoineBo » 12 avril 2019, 14:11

78chris a écrit :
12 avril 2019, 12:28
Bonjour

A tester
=SI($B$2:$B$66=D2;MIN(($A$2:$A$66)*1);"")
Je ne suis pas certain que cela fasse avancer mon problème, à moins de ne pas bien comprendre.

Je poste une version mise à jour, je ne sais pas comment intégrer dans la formule le fait que si le numéro d'intervalle est unique en colonne B (ce qui veut dire que le numéro de pièce ne suit pas un autre et n'est pas suivi) alors qu'il inscrive en début et fin d'intervalle ce même numéro de pièce.

Exemple en intervalle numéro 10 dans le fichier en PJ.
Intervalles.xlsx
(41.06 Kio) Téléchargé 4 fois
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'159
Appréciations reçues : 353
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 12 avril 2019, 14:18

Bonjour,

je ne vois pas trop le lien entre tes explications qui annoncent 3 colonnes et le fichier que tu fournis.

Plutôt qu'une formule manifestement fausse, met le résultat attendu en expliquant le pourquoi et le comment.
eric
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
A
AntoineBo
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 6 mars 2019
Version d'Excel : 2016 FR

Message par AntoineBo » 12 avril 2019, 14:21

eriiic a écrit :
12 avril 2019, 14:18
Bonjour,

je ne vois pas trop le lien entre tes explications qui annoncent 3 colonnes et le fichier que tu fournis.
eric
Ce n'était qu'un exemple d'illustration, le fichier fourni fait foi. C'était une manière d'expliquer le problème avant d'avoir à ouvrir le fichier, mais il ne faut tenir compte que de ce dernier.
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'159
Appréciations reçues : 353
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 12 avril 2019, 14:22

J'ai édité mon post, relis.
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'159
Appréciations reçues : 353
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 12 avril 2019, 14:28

Ah, je crois avoir compris ce que tu veux.
En E1 :
=INDEX(A:A;EQUIV(D2;B:B;0))
en F1 :
=INDEX(A:A;EQUIV(D2;B:B;0)+NB.SI(B:B;D2)-1)
eric
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
A
AntoineBo
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 6 mars 2019
Version d'Excel : 2016 FR

Message par AntoineBo » 12 avril 2019, 14:37

eriiic a écrit :
12 avril 2019, 14:28
Ah, je crois avoir compris ce que tu veux.
En E1 :
=INDEX(A:A;EQUIV(D2;B:B;0))
en F1 :
=INDEX(A:A;EQUIV(D2;B:B;0)+NB.SI(B:B;D2)-1)
eric
C'était exactement ça merci.

Très bonne journée.
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'159
Appréciations reçues : 353
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 12 avril 2019, 15:08

:btres:
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message