creer un texte dans une case en tappant un chiffre dans une autre ! Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
T
Thomas-D
Nouveau venu
Nouveau venu
Messages : 9
Appréciation reçue : 1
Inscrit le : 3 janvier 2019
Version d'Excel : office 15

Message par Thomas-D » 3 janvier 2019, 17:53

Bonjour à tous, je suis tout nouveau sur le forum mais je n'arrive pas a trouver une réponse a ma question donc je me suis inscrit afin de voir si quelqu'un peut m'aider..

Je voudrais que dans une colonne " A" je puisse rentrer un chiffre 1,2,3... et que dans la colonne "B" apparaisse un mot associer a ce code, c'est pour une création de fiche recette soit: colonne A ligne 1 je tape 1, colonne B ligne 1 apparait "lait".. colonne A ligne 2 je tape 2, colonne B ligne 2 apparait " beurre" etc ... si en plus je peux avoir ma base d'ingrédients sur une autre feuille et juste avoir une feuille avec ma recette ce serait parfait !!

j'espere que ma demande est assez précise, merci d'avance !!

j'en ai une autre après c'est pour un calcul de coût, je voudrais créer un base de prix par ingrédients sur une feuille récapitulative et sur ma fiche de recette ( la même que la premiere demande ) je puisse en fonction de la quantité utilisée faire apparaitre le cout de ma fabrication dans ma colonne "coût", merciii
j
jmd
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'599
Appréciations reçues : 250
Inscrit le : 8 décembre 2007
Version d'Excel : 365 + PowerBI

Message par jmd » 3 janvier 2019, 18:04

bonjour

faisable avec la fonction RECHERCHEV

joins un fichier de 3 colonnes et 5 lignes de données

à te relire
amitiés
Apprenez les fonctions d'Excel.
Exemple "Mettre sous forme de tableau", TCD, "Récupérer des données".
Apprendre les fonctionnalités "récentes".
A
Andre13
Membre impliqué
Membre impliqué
Messages : 1'771
Appréciations reçues : 120
Inscrit le : 13 juillet 2017
Version d'Excel : 2007-2013

Message par Andre13 » 3 janvier 2019, 18:20

Bonjour toutes et tous,

coucou Jmd ;;)

à tester à améliorer ci-joint, un petit aperçu avec validation des Données + recherchev
crdlt,
André
laitbeurreoeuf_v1.xlsx
(15.21 Kio) Téléchargé 5 fois
T
Thomas-D
Nouveau venu
Nouveau venu
Messages : 9
Appréciation reçue : 1
Inscrit le : 3 janvier 2019
Version d'Excel : office 15

Message par Thomas-D » 3 janvier 2019, 18:55

ok, merci andre effectivement cela fonctionne avec ta "mise en page " mais ce n'est pas la mienne du coup je n'arrive pas a l'adapter a mon tableau deja existant, ci joint le debut de mon travail, merci
dossier recettes JTM.xlsx
(12.06 Kio) Téléchargé 5 fois
dossier recettes JTM.xlsx
(12.06 Kio) Téléchargé 5 fois
A
Andre13
Membre impliqué
Membre impliqué
Messages : 1'771
Appréciations reçues : 120
Inscrit le : 13 juillet 2017
Version d'Excel : 2007-2013

Message par Andre13 » 3 janvier 2019, 19:24

Bonjour toutes et tous

ci-joint à tester
crdlt,
André
dossier recettes JTM_v1.xlsx
(18.28 Kio) Téléchargé 5 fois
T
Thomas-D
Nouveau venu
Nouveau venu
Messages : 9
Appréciation reçue : 1
Inscrit le : 3 janvier 2019
Version d'Excel : office 15

Message par Thomas-D » 3 janvier 2019, 20:28

je pars manger, je n'arrive pas à remettre la formule sur mon dossier existant, je ne comprend pas la liste que tu as mis dans ta formule car je ne sais pas me servir de la rechercheV, je regarde ca apres, merci en tout cas je vais y arriver a force :)
A
Andre13
Membre impliqué
Membre impliqué
Messages : 1'771
Appréciations reçues : 120
Inscrit le : 13 juillet 2017
Version d'Excel : 2007-2013

Message par Andre13 » 3 janvier 2019, 20:43

Re, bonne appétit,
en images :
1/ voir les images en premier
2/ voir le texte ci-dessous ensuite

En B6 de l'onglet 'FT type' de ton classeur 'dossier recettes JTM_v1.xlsx'
la formule:
=RECHERCHEV($A$6;'dossier recettes JTM_v1.xlsx'!CODEC;2;FAUX)
puis,
j'ai tiré cette formule jusqu'en bas, ensuite, de la cellule D6 toujours sur la même feuille (Poids)
pour y introduire la formule:
=RECHERCHEV(A6;'dossier recettes JTM_v1.xlsx'!CODEMATPRIX;3;FAUX)
crdlt,
André
z2.png
z2.png (14.28 Kio) Vu 140 fois
ztestmatiere1.png
ztestmatiere1.png (36.53 Kio) Vu 140 fois
T
Thomas-D
Nouveau venu
Nouveau venu
Messages : 9
Appréciation reçue : 1
Inscrit le : 3 janvier 2019
Version d'Excel : office 15

Message par Thomas-D » 3 janvier 2019, 21:31

merci :)

quand je tape la formule que tu m'as donner en B6 une fenetre de recherche de dossiers s'ouvre et me dit " mettre a jour les valeurs " ... et si je selectionne dossier recettes JTM je me retrouve avec #NOM? ... je ne comprend pas :(
A
Andre13
Membre impliqué
Membre impliqué
Messages : 1'771
Appréciations reçues : 120
Inscrit le : 13 juillet 2017
Version d'Excel : 2007-2013

Message par Andre13 » 3 janvier 2019, 21:48

Re,
ci-joint le fichier, en espérant que cela puisse t'aidé
il faut que peut être dans la colonne A, tu es des chiffres
aussi non, il faudra ajouter à la formule si cellule vide de la colonne A

(voir image si, cela fait comme sur l'image ci-jointe)
(voir image en plaçant dans la formule =SI(ESTERREUR...))

Donc en B6 pour ne pas voir les dièses na (#N/A)
=SI(ESTERREUR(RECHERCHEV(A6;'dossier recettes JTM_v2.xlsx'!CODEC;2;FAUX));"";RECHERCHEV(A6;'dossier recettes JTM_v2.xlsx'!CODEC;2;FAUX))
Donc, en D6 (Poids) pour ne pas voir également les #N/A :
=SI(ESTERREUR(RECHERCHEV(A6;'dossier recettes JTM_v2.xlsx'!CODEMATPRIX;3;FAUX));"";RECHERCHEV(A6;'dossier recettes JTM_v2.xlsx'!CODEMATPRIX;3;FAUX))
crdlt,
André
zdiesena.png
zdiesena.png (5.93 Kio) Vu 126 fois
dossier recettes JTM_v2.xlsx
(18.25 Kio) Téléchargé 1 fois
ztest111.png
ztest111.png (57.81 Kio) Vu 132 fois
T
Thomas-D
Nouveau venu
Nouveau venu
Messages : 9
Appréciation reçue : 1
Inscrit le : 3 janvier 2019
Version d'Excel : office 15

Message par Thomas-D » 3 janvier 2019, 22:14

ok, on a pas trop comprit en faites comment tu as fait le " CODEC " donc voila comment on a fait, regarde les formules, je ne sais pas si c'est tres conventionnel mais ca fonctionne
dossier recettes JTM.xlsx
(14.26 Kio) Téléchargé 3 fois
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message