Comptage d'occurences textes dans excel

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
b
beas
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 25 octobre 2006

Message par beas » 25 octobre 2006, 16:12

Bonjour,

Je cherche à compter des occurences textes multiples par une fonction Excel :
J'ai 2500 lignes et une colonne dans laquelle j'ai des caractères de type : C1007501 - C1207505 - HARE7502 ... en tout 267 codes différents.
Répètés chacuns sur plusieurs lignes.

Je voudrais avoir le total du nombre d'occurences différentes et non le nombre total d'occurence.
Ex : 10 fois C1007501 - 20 fois C1207505 - 5 fois HARE7502, me donnerais 4 puisque en tout j'ai 4 fois le même code (et non pas 35)
Je n'y arrive pas avec NB.SI, puisque je n'ai pas de critère défini, ni avec SOUS.TOTAL, ni avec SOMME.SI ...

Est-ce que quelqu'un peut m'aider.

Merci d'avance
A
Amadéus
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'620
Appréciations reçues : 79
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 25 octobre 2006, 17:16

Bonjour Beas

Il doit y avoir quelque chose qui m'échappe.
Tu as 267 codes identifiés dans une colonne et tu veux savoir combien sont sur ta Feuille?
Supposons que tes codes soient colonne Y, si tu écris en Z =NB.SI(Plage;C100750), tu obtiens comme tu dis 10 (pour 10 fois)
Mai si tu écris SI(NB.SI(Plage;C100750)>0;1;0) et que tu incrémente sur tes 267 Codes, tu aura bien, en additionnant cette colonne le nombre de Codes utilisés qui sera au plus égal à 267.
Si ce n'est pas ce que tu cherches, il faut (en tout cas pour moi) un peu plus d'explications. Si c'est le cas, n'hésites pas à relancer.

Cordialement,

Amadéus

Si tu écris dans la
b
beas
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 25 octobre 2006

Message par beas » 25 octobre 2006, 17:36

Mais je ne voudrais qu'un résultat affiché en en-tête de colonne et pas une colonne supplémentaire (j'en ai déjà 15)

Avec le fichier joint ce sera + simple (je l'ai réduit)

En fait le but c'est de :
1. Dénombrer le nombre de codes différents au total
2 Dénombrer le nombre de codes différent pour les filtres sélectionnés

Le nombre de code total devrait s'afficher dans la cellule A1
Le nombre de code pour filtre dans la cellule B1

https://www.excel-pratique.com/~files/doc/listebeas.xls
b
beas
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 25 octobre 2006

Message par beas » 26 octobre 2006, 09:57

:D :idea:
J'ai trouvé la réponse à une partie de ma demande avec la fonction de macro complémentaire NB.DIFF de Morefunc ...
Génial...

Si quelqu'un est cap de faire une macro complémentaire pour utilisation de ce code sur éléments filtrés (même principe que SOUS.TOTAL - dénombre les seuls éléments affichés à l'écran ), ça serait vraiment le top du top (moi je peux pas : la prog c'est pas mon domaine ...) - Pour des pro de la prog ça doit être facile ...

Non !? Ah bon, pardon... :oops:
A
Amadéus
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'620
Appréciations reçues : 79
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 26 octobre 2006, 15:53

Bonjour beas
En effet, j'ai téléchargé Morefunc, c'est génial.
Ainsi en A1, =NB.DIFF($B$4:$B$480) donne 56
et en B1, =SOUS.TOTAL(103;($B$4:$B$480)) donne effectivement le nombre de lignes affichées aprés filtrage.

On apprend tous les jours.

Cordialement

Amadéus
J
JeanMarie
Membre fidèle
Membre fidèle
Messages : 276
Inscrit le : 3 décembre 2006

Message par JeanMarie » 3 décembre 2006, 16:16

Bonjour

Une autre solution pour trouver la valeur 56
=SOMME((FREQUENCE(EQUIV(B4:B480;B4:B480;0);LIGNE(1:480))>0)*1)

@+Jean-Marie
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message