Existe-t-il une formule pour ça ? Le sujet est résolu

Y compris Google Docs, Slides et toute autre question en lien avec une application Google
j
jadew
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 25 juillet 2019

Message par jadew » 25 juillet 2019, 15:03

Bonjour à tous,

Je cherche à faire quelque chose sur Google Sheet mais je ne sais même pas si une formule existe pour le faire... Un pro d'Excel peut-il m'éclairer svp ?

Voilà le problème (simplifié) :
J'ai une colonne A avec un texte sur chaque ligne, et à côté sur une colonne B une case à cocher sur chaque ligne. On a donc :

____________Colonne A________Colonne B
Ligne 1______"Texte 1"______[Case à cocher]
Ligne 2______"Texte 2"______[Case à cocher]
Ligne 3______"Texte 3"______[Case à cocher]

Sur une autre colonne (disons C), j'aimerais que :
- Si la case en B1 est cochée, alors le texte en A1 (littéralement "Texte 1") s'affiche dans une autre cellule à côté (disons C1)
- Si la case en B1 n'est pas cochée, alors le contenu de cette même cellule (C1) reste vide

Idem si je coche B3, alors C3 affiche le contenu de A3. Si je coche B2 alors C2 affiche A2.

Évidemment, je précise que j'ai simplifié le problème pour mon explication. En réalité, une formule qui automatise ainsi le contenu d'une cellule par rapport aux cases que je coche me serait utile pour une question de visibilité. La "Colonne C" dans mon exemple est en fait une colonne sur une autre feuille, j'aimerais donc pouvoir appercevoir dans une colonne sur ma feuille 2, ce qui a été coché sur ma feuille 1.

Un grand merci d'avance à la personne qui saura m'indiquer la formule :)
Avatar du membre
Pedro22
Membre impliqué
Membre impliqué
Messages : 2'815
Appréciations reçues : 282
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 25 juillet 2019, 15:06

Bonjour,

Je crois savoir que les cases à cocher renvoie une valeur FAUX (ou 0) lorsqu'elle n'est pas cochée, VRAI (ou 1) le cas inverse. Il te suffit donc d'écrire en C1 (SI = IF en anglais, si besoin) :
=SI(B1;A1;"")
Cette formule peut-être étendue à l'ensemble de tes lignes.

PS : formule vérifiée et fonctionnelle...
exemple_jadew.jpg
exemple_jadew.jpg (28.74 Kio) Vu 224 fois
Merci de prendre 30 sec pour lire la charte du forum.
j
jadew
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 25 juillet 2019

Message par jadew » 25 juillet 2019, 16:29

Pedro22 merci pour ta réponse rapide ! Effectivement, ça fonctionne !
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message