Incrémentation automatique Le sujet est résolu

Y compris Google Docs, Slides et toute autre question en lien avec une application Google
L
Lorenzoforte
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 25 octobre 2018
Version d'Excel : 2016 FR

Message par Lorenzoforte » 5 août 2019, 14:23

Bonjour,

je possède un fichier dont j'aimerais modifier l'incrémentation automatique. Actuellement lorsque j'entre une date dans la colonne A, la colonne C incrémente automatiquement des numéro par ex 07-00, 07-01, 07-02,... ce sont des numéros servants à numéroter des quittances. Seulement chaque écriture ne possède pas forcément une quittance et j'aimerais donc que ce numéro s'incrémente seulement si la colonne B possède un X pour indiquer qu'il y a bien une quittance et que celle-ci soit numéroter à la suite de la quittance précédente.

voici en lien le fichier actuel.

https://drive.google.com/file/d/1bgUqdL2QB1ju3UwtuUIrXOVlHNiglkbU/view?usp=sharing

merci pour votre aide !!! :)

Lorenzo
Avatar du membre
curulis57
Membre impliqué
Membre impliqué
Messages : 2'827
Appréciations reçues : 90
Inscrit le : 4 janvier 2016
Version d'Excel : 2013 FR

Message par curulis57 » 8 août 2019, 21:08

Salut Lorenzo,

joins ton fichier simplement dans ton post : impossible de l'exploiter de cette manière!

A+
m
m3ellem1
Membre dévoué
Membre dévoué
Messages : 841
Appréciations reçues : 57
Inscrit le : 18 décembre 2018
Version d'Excel : 2016

Message par m3ellem1 » 8 août 2019, 22:22

Salut,

un essai:
il faut faire attention au format des dates de la colonne A, car la formule entrée dans la colonne C calcule le numéro du mois, ce qui veux dire que si le mois change il change le numéro de 07-00 .... pour juillet à 08-00 .... pour aout et ainsi de suite

formule à entrer dans C9 et tu tires vers le bas
=SI(B9="";"";TEXTE(MOIS(A9);"00")&"-"&TEXTE(SOMMEPROD((MOIS($A$9:A9)=MOIS(A9))*($B$9:B9="x"))-1;"00"))
voir fichier aussi
modif compta.xlsx
(40.25 Kio) Téléchargé 2 fois
@++
Avatar du membre
Sébastien
Administrateur
Administrateur
Messages : 2'033
Appréciations reçues : 185
Inscrit le : 4 décembre 2004
Version d'Excel : 2016 FR
Version de Sheets : FR
Contact :
Téléchargements : Mes applications

Message par Sébastien » 8 août 2019, 22:29

Bonjour,

Si tu postes un fichier au format xlsx, tu as tout intérêt à le joindre directement comme pièce jointe pour avoir plus de réponses ;;)

Une solution :
=SI(B9="X";"07-"&TEXTE(NB.SI(B$8:B9;"X");"00");"")
quittance-excel.png
modif compta.xlsx
(25.38 Kio) Téléchargé 1 fois
Cordialement,
Sébastien
L
Lorenzoforte
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 25 octobre 2018
Version d'Excel : 2016 FR

Message par Lorenzoforte » 9 août 2019, 17:20

woaow !!!! Alors là ça sort largement au-delà de mes compétences :lole: merci beaucoup c'est exactement ce que je voulais, les deux version sont niquel mais c'est encore mieux avec le premier numéro qui fait automatiquement référence au mois de m3ellem1 !! merci les gars !!!!! =D
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message