trouver si une cellule contient un des mots d'une liste

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
d
dann
Membre fidèle
Membre fidèle
Messages : 328
Inscrit le : 19 février 2014
Version d'Excel : 2007

Message par dann » 28 septembre 2017, 08:22

bonjour,

je cherche une formule qui permettrait d afficher en a1; la valeur de 1, si en a2, la cellule contient un des mots " transistor ou condensateur ou résistance" ... sinon, afficher la valeur 0

je n arrive pas à faire une formule avec un "ou "

merci
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'006
Appréciations reçues : 421
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 28 septembre 2017, 08:30

Bonjour,

Pour une réponse toute électrique .... :D

Ci-joint ton fichier test ... :wink:

En espèrant que cela t'aide ...
Test dann.xlsx
(7.64 Kio) Téléchargé 370 fois
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 28 septembre 2017, 08:47

Bonjour le forum,
=SOMMEPROD(--(A2={"transistor"."condensateur"."résistance"}))
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 28 septembre 2017, 10:00

dann a écrit :je n arrive pas à faire une formule avec un "ou "
Ou :
=SI(OU(A2="condensateur";A2="résistance";A2="transistor");1;0)
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 28 septembre 2017, 13:50

Ou :
=MAX(NB.SI(A2;"condensateur")+NB.SI(A2;"résistance")+NB.SI(A2;"transistor");0)
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message