Si une cellule contient une donnée dans une liste alors.... Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
d
doublebulle
Jeune membre
Jeune membre
Messages : 24
Inscrit le : 17 janvier 2017
Version d'Excel : 2007

Message par doublebulle » 9 juin 2017, 22:56

Bonsoir à tous,

Voici ma demande :

Si la donnée de la cellule A1 se trouve dans une liste (B1:B12) alors écrire 1 en C1 sinon écrire 0.

A écrire cela à l'air simple mais impossible de trouver une formule qui fonctionne.

Par avance, merci à toute personne qui m'apportera son aide.

Greg
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 9 juin 2017, 22:58

Bonsoir le forum,
=SI(NB.SI(B1:B12;A1)>0;1;0)
d
doublebulle
Jeune membre
Jeune membre
Messages : 24
Inscrit le : 17 janvier 2017
Version d'Excel : 2007

Message par doublebulle » 9 juin 2017, 23:08

Bonsoir mbbp,

Merci, c'est parfait.
Je compliquais trop la chose.
Bon week end.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 9 juin 2017, 23:13

Merci pour la réponse.

Ou :
=MIN(NB.SI(B1:B12;A1);1)
d
doublebulle
Jeune membre
Jeune membre
Messages : 24
Inscrit le : 17 janvier 2017
Version d'Excel : 2007

Message par doublebulle » 9 juin 2017, 23:26

Merci mais la première est nickel.
Ce que je ne saisi pas c'est le >0
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 9 juin 2017, 23:33

La seconde formule fonctionne aussi bien que la première.

>0 car la donnée de la cellule A1 peut ainsi se trouver une ou plusieurs fois dans la liste B1:B12.
Modifié en dernier par mbbp le 9 juin 2017, 23:40, modifié 1 fois.
d
doublebulle
Jeune membre
Jeune membre
Messages : 24
Inscrit le : 17 janvier 2017
Version d'Excel : 2007

Message par doublebulle » 9 juin 2017, 23:37

Très bien.
Merci de ton aide.
@+
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message