Ne pas supprimer les 000 Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
S
Sweety
Membre habitué
Membre habitué
Messages : 65
Inscrit le : 27 novembre 2016
Version d'Excel : 2010

Message par Sweety » 18 février 2017, 18:10

Bonjour,

J'ai une référence 000-008-158 et je veux 0000008158 et j'obtiens 8158.

Je mets pourtant Données convertir- largeur fixe ou délimité texte.

Pouvez vous m'aider

Merci d avance
Avatar du membre
jpbt84
Membre dévoué
Membre dévoué
Messages : 561
Appréciations reçues : 7
Inscrit le : 18 juin 2016
Version d'Excel : Pro Plus 2019 FR

Message par jpbt84 » 18 février 2017, 18:13

Bonjour,

Vous pouvez définir la cellule comme étant du texte (Dans le format)
ou encore commencer la référence avec une apostrophe ', elle n'apparaitra pas dans la visualisation.

Bien à vous.
Jp

:btres:
Formateur bureautique, certifié ECDL Expert
Avatar du membre
M12
Passionné d'Excel
Passionné d'Excel
Messages : 3'259
Appréciations reçues : 133
Inscrit le : 3 juillet 2015
Version d'Excel : 2013

Message par M12 » 18 février 2017, 18:15

Bonjour,

si ta donnée est en A1, met en A2 par exemple
=SUBSTITUE(A1;"-";"")
Merci de clôturer le fil en cliquant sur le bouton V vert du post à coté du bouton EDITER si problème résolu

Je ne répond pas au message privé
Avatar du membre
Yvouille
Passionné d'Excel
Passionné d'Excel
Messages : 9'154
Appréciations reçues : 96
Inscrit le : 6 avril 2007
Version d'Excel : 2016

Message par Yvouille » 18 février 2017, 18:21

Salut,

Dans le fichier ci-joint j'ai inscrit 000-008-158 en A1.

En B1 j'ai placé la formule =SUBSTITUE(A1;"-";"") et il y a le résultat 000008158. Excel a gardé le format "Standard" et cette suite de signes n'est pas considérée comme un nombre, mais comme du texte.

En C1 j'ai multiplié B1 par 1, Excel modifie donc immédiatement le format et inscrit un nombre sans les 0 devant.

En D1, j'ai reproduis la cellule C1, mais en utilisant le format de nombre personnalisé "000000000" et mon nombre est visible ainsi : 000008158.

A quoi ressemble ton fichier ? Comment obtiens-tu le chiffre ou le nombre que tu voudrais voir au format "000000000" ?

Cordialement.
Essai format.xlsx
(10.35 Kio) Téléchargé 13 fois
Yvouille

Valais de Coeur
J
JFL
Membre impliqué
Membre impliqué
Messages : 1'333
Inscrit le : 1 avril 2011
Version d'Excel : 2010 FR, 2013 FR

Message par JFL » 18 février 2017, 18:34

Bonsoir,

et si votre besoin est d'avoir un résultat sur 10 positions, je vous propose la formule suivante :
=TEXTE(SUBSTITUE(A1;"-";"");"0000000000")
Cordialement

JF
S
Sweety
Membre habitué
Membre habitué
Messages : 65
Inscrit le : 27 novembre 2016
Version d'Excel : 2010

Message par Sweety » 19 février 2017, 09:39

Merci pour votre aide
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message