Afficher la cellule à côté de celle du résultat Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
D
Dot
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 10 février 2017
Version d'Excel : 2013

Message par Dot » 10 février 2017, 13:24

Bonjour,

Je cherche un peu d'aide après plusieurs heures de recherches, merci à ceux qui passeront par ici pour tenter de m'aider ;)
Help.xlsx
(332.98 Kio) Téléchargé 12 fois
Voilà mon problème sur le fichier Excel que je vous joint (en version raccourcie) j'ai :
Colonne A : Nom de ville
Colonne B : Nombre de garagistes dans la ville

Colonne D : Nom des communes de France
Colonne E : Nombre d'habitants par communes

Je voudrais qu'en colonne F apparaisse :
Cas 1 - 0 si la commune n'est pas dans la colonne A car elle n'a pas de garagiste
Cas 2 - Et si la commune est dans la colonne A et D, que le bon nombre (correspondant à la bonne commune) de la colonne B apparaisse.

Où j'en suis pour le moment, j'ai fais en colonne F la formule suivante :
=SI(ESTNA(RECHERCHEV(D:D;$A$1:$A$10240;1;FAUX));"0";(RECHERCHEV(D:D;$A$1:$A$10240;1;FAUX)))
Donc dans le
Cas 1 : j'ai bien un retour de 0
et dans le Cas 2 : J'ai le nom de la commune prise en colonne A

J'ai testé pas mal de formules comme par exemple mettre en colonne G :
=SI(F:F<>"0";B:B;FAUX)
Mais quand je déroule ma formule pour qu'elle s'applique à toutes les cellules de la colonne, j'ai effectivement le nombre de la colonne B qui apparaît mais pas le bon (assez complexe à expliquer je vous laisse le voir via le fichier et le screenshot).
help_excel.jpg
Les flèches rouges sont correspondent à ce que la formule me fait et les vertes à ce j'aurais voulu...

Voilà donc si quelqu'un à une idée je prend :)
Merci par avance
A
Amadéus
Modérateur
Modérateur
Messages : 17'742
Appréciations reçues : 66
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 10 février 2017, 14:09

Bonjour
En F1, incrémenté vers le bas
=SI(NB.SI(A:A;D1);RECHERCHEV(D1;A:B;2;FAUX);0)
Cordialement
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
Avatar du membre
Raja
Passionné d'Excel
Passionné d'Excel
Messages : 5'156
Appréciations reçues : 7
Inscrit le : 3 février 2008
Version d'Excel : 2010 à 2016 FR et 2010 EN

Message par Raja » 10 février 2017, 14:14

Bonjour,

Je ne suis pas sur d'avoir tout compris. Essaye la formule suivante en F1 et copie vers le bas :
=SIERREUR(INDEX(B:B;EQUIV(D1;A:A;0));0)
Cdlt,
Raja
D
Dot
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 10 février 2017
Version d'Excel : 2013

Message par Dot » 10 février 2017, 14:34

Les deux méthodes m'ont l'air de bien fonctionner !
Merci beaucoup :)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message