Remplir colonne B en fonction d'intervalles dans colonne A Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
J
JeanneetClaire
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 19 octobre 2016
Version d'Excel : 2003 FR

Message par JeanneetClaire » 13 janvier 2017, 14:37

Bonjour,

Je souhaiterais trouver un code me permettant d'attribuer à ma colonne "CODE_NICHEUR" un chiffre allant de 1 à 3 correspondant aux chiffres présents dans ma colonne "CODE_ATLAS".
En fait : - pour un chiffre allant de 2 à 3 dans ma colonne "CODE_ATLAS" il faut attribuer un 3 en colonne "CODE_NICHEUR",
- pour un chiffre allant de 4 à 10 dans ma colonne "CODE_ATLAS" il faut attribuer un 2 en colonne "CODE_NICHEUR"
- pour un chiffre allant de 11 à 19 dans ma colonne "CODE_ATLAS" il faut attribuer un 1 en colonne "CODE_NICHEUR"

Il y a également des codes 99, 30, 40, 50 et des cases vides dans la colonne "CODE_ATLAS", mais j'aimerais que le code n'en tienne pas compte.

Voilà ! Merci de votre aide si vous arrivez à trouver quelque chose. :D :D
Classeur1.xls
Voilà le fichier en question.
(13.5 Kio) Téléchargé 15 fois
A
Amadéus
Modérateur
Modérateur
Messages : 17'733
Appréciations reçues : 62
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 13 janvier 2017, 16:08

Bonjour
En B2, incrémentée vers le bas
=SI(OU(A2=2;A2=3);3;SI(ET(A2>3;A2<11);2;SI(ET(A2>10;A2<20);1;"")))
Cordialement
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'186
Appréciations reçues : 180
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 13 janvier 2017, 16:26

bonjour;re Amadeus
a voir
=SIERREUR(INDEX({3.2.1.1};EQUIV(A2;{2;4;10;11;19};1));"")
c'est en cherchant qu'on trouve
J
JeanneetClaire
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 19 octobre 2016
Version d'Excel : 2003 FR

Message par JeanneetClaire » 16 janvier 2017, 11:21

Merci beaucoup pour la réponse Amadéus !!
Ça marche super bien. :D
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message