Remplir colonne B en fonction d'intervalles dans colonne A

Bonjour,

Je souhaiterais trouver un code me permettant d'attribuer à ma colonne "CODE_NICHEUR" un chiffre allant de 1 à 3 correspondant aux chiffres présents dans ma colonne "CODE_ATLAS".

En fait : - pour un chiffre allant de 2 à 3 dans ma colonne "CODE_ATLAS" il faut attribuer un 3 en colonne "CODE_NICHEUR",

- pour un chiffre allant de 4 à 10 dans ma colonne "CODE_ATLAS" il faut attribuer un 2 en colonne "CODE_NICHEUR"

- pour un chiffre allant de 11 à 19 dans ma colonne "CODE_ATLAS" il faut attribuer un 1 en colonne "CODE_NICHEUR"

Il y a également des codes 99, 30, 40, 50 et des cases vides dans la colonne "CODE_ATLAS", mais j'aimerais que le code n'en tienne pas compte.

Voilà ! Merci de votre aide si vous arrivez à trouver quelque chose.

16classeur1.xls (13.50 Ko)

Bonjour

En B2, incrémentée vers le bas

=SI(OU(A2=2;A2=3);3;SI(ET(A2>3;A2<11);2;SI(ET(A2>10;A2<20);1;"")))

Cordialement

bonjour;re Amadeus

a voir

=SIERREUR(INDEX({3.2.1.1};EQUIV(A2;{2;4;10;11;19};1));"")

Merci beaucoup pour la réponse Amadéus !!

Ça marche super bien.

Rechercher des sujets similaires à "remplir colonne fonction intervalles"