Si et recherchev combinés???

Y compris Power BI, Power Query et toute autre question en lien avec Excel
N
NARIES2016
Jeune membre
Jeune membre
Messages : 24
Inscrit le : 3 novembre 2016
Version d'Excel : 2010

Message par NARIES2016 » 29 décembre 2016, 20:21

Bonsoir à tous!
J'aurais besoin de pouvoir compter le nombre de valeurs correspondant à un titre, et répondant à une condition... j'imagine qu'il faut utiliser un SI et pourquoi pas un RECHERCHEV, mais je n'arrive pas à construire ma formule...

Quelqu'un a-t-il une idée?

Ci-joint: un exemple de tableau:
Colonne A: des noms d'étangs
Colonne B: leur quantité en eau (plusieurs valeurs pour un même étang parfois)

Colonne G: liste des étangs différents
Colonne H: nombre d'occurrence de chaque étang dans la plage de base
Colonne I: ???!!! Il me faut, pour chaque étang, le nombre d'occurrences (parmi celles comptées en colonne H logiquement), qui valent 0 et 1.

Merci d'avance! ;-)
Bonnes fêtes à tous!
Test water.xlsx
(10.23 Kio) Téléchargé 9 fois
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'682
Appréciations reçues : 237
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 29 décembre 2016, 20:46

bonjour
voila
tout est automatisé
naries 2016.xlsx
(12.06 Kio) Téléchargé 13 fois
cordialement
c'est en cherchant qu'on trouve
N
NARIES2016
Jeune membre
Jeune membre
Messages : 24
Inscrit le : 3 novembre 2016
Version d'Excel : 2010

Message par NARIES2016 » 29 décembre 2016, 21:28

Wow!!! Quelle rapidité!
Ca a l'air nickel! Sauf qu'il me faut >= 1, donc il me faut inclure le 0 et le 1 dans les comptes...
Tu peux me dire comment modifier stp?

Merci bcp!
Emilie

*EDIT: J'ai mis <2 dans la formule de la colonne I et ça joue vu que dans mes quantités, je n'ai rien entre 1 et 15!
Merci beaucoup beaucoup!
Bonne soirée à toi!
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'371
Appréciations reçues : 398
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 29 décembre 2016, 22:33

Bonjour,

Avec un TCD.
eric
naries 2016.xlsx
(19.33 Kio) Téléchargé 7 fois
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
A
AYARI Moncef
Jeune membre
Jeune membre
Messages : 41
Inscrit le : 29 décembre 2016
Version d'Excel : 2007

Message par AYARI Moncef » 29 décembre 2016, 23:31

Bonsoir

Essayer la formule suivante

=SOMMEPROD(($A$2:$A$51=G2)*($B$2:$B$51<=1)*1)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message