Écart entre 2 valeurs format horaire

Y compris Power BI, Power Query et toute autre question en lien avec Excel
d
davsasse
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 4 décembre 2016
Version d'Excel : 2007

Message par davsasse » 10 décembre 2016, 16:44

Bonjour à tous !

Je réalise un tableau sur Excel 2007, il s'agit d'un classement pour course automobile.

J'ai une colonne de mon tableau qui donne un temps au format horaire pour chaque concurrent, et une colonne à côté destinée à calculer l'écart du temps de chaque concurrent par rapport à un temps théorique (cellule fixée avec $ hors du tableau).
J'ai simplement fait une formule de soustraction. Cela marche parfaitement lorsque cet écart est positif, mais lorsque l'écart est négatif (c'est à dire que le concurrent a mis moins de temps que le temps théorique), le calcul ne marche pas et j'obtient ######## (ligne 59 de mon tableau,voir photo jointe)

Avez vous la solution?

Merci d'avance !

Davsasse
Capture.JPG
Avatar du membre
bernard22
Membre dévoué
Membre dévoué
Messages : 872
Appréciations reçues : 9
Inscrit le : 26 mars 2015
Version d'Excel : 2013FR

Message par bernard22 » 10 décembre 2016, 17:02

Bonsoir,


=SI(G2>D2;"-"&TEXTE(G2-D2;"hh:mm:ss");D2-G2)
ou
=SI(G4>D4;TEXTE(G4-D4;"-hh:mm:ss");D4-G4)

Avertissement: ce n'est pas une solution acceptable si tu as besoin d'utiliser le résultat dans un autre calcul.

Un fichier serait mieux qu'une copie d'écran

@+
d
davsasse
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 4 décembre 2016
Version d'Excel : 2007

Message par davsasse » 10 décembre 2016, 17:06

Merci de votre réponse.

D'accord, seulement je n'arrive pas à utiliser votre formule car je ne dois pas mettre les bonnes références de cases. Voici mon fichier
Tableau Classement 2ème Balade de la Burle.xlsx
(18.58 Kio) Téléchargé 9 fois
Avatar du membre
bernard22
Membre dévoué
Membre dévoué
Messages : 872
Appréciations reçues : 9
Inscrit le : 26 mars 2015
Version d'Excel : 2013FR

Message par bernard22 » 10 décembre 2016, 17:15

Bonsoir,
Regarde si cela te convient
Tableau Classement 2ème Balade de la Burle.xlsx
(18.7 Kio) Téléchargé 9 fois
f
frangy
Passionné d'Excel
Passionné d'Excel
Messages : 4'342
Inscrit le : 19 novembre 2012
Version d'Excel : 2007 FR

Message par frangy » 10 décembre 2016, 17:23

Bonjour,

Une autre solution pour autoriser les valeurs négatives consiste à modifier le système de date pour le système de date Calendrier depuis 1904.
Options > Options avancées > Utiliser la calendrier depuis 1904.

Mais attention aux problèmes lors de la liaison ou copier de dates entre classeurs si les ces classeurs utilisent des systèmes de date différents (décalages de dates).

A+
Tableau Classement V2.xlsx
(18.65 Kio) Téléchargé 8 fois
d
davsasse
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 4 décembre 2016
Version d'Excel : 2007

Message par davsasse » 10 décembre 2016, 17:30

D'accord j'ai compris (même si la solution de Bernard est un peu dure pour mon niveau haha)

Merci Bernard et Frangy de m'avoir consacré un peu de temps, c'est parfait !!

Merci et bonne soirée
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message