extraction alphanumérique (Prob : format AM PM) Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
Avatar du membre
spage
Membre habitué
Membre habitué
Messages : 94
Appréciations reçues : 2
Inscrit le : 3 février 2014
Version d'Excel : 2010

Message par spage » 7 décembre 2016, 13:44

BOnjour à tous,

J'ai trouvé cette magnifique formule qui fonctionne à merveille pour extraire un nombre d'une chaîne alphanumérique

=SIERREUR(RECHERCHE(9^9;--("0"&STXT(A2;MIN(CHERCHE({0.1.2.3.4.5.6.7.8.9};A2&"0 123456789"));LIGNE($1:$100))));"")

Le seul hic, c'est lorsque la chaîne alphanumérique contient un nombre suivi de la lettre p ou a, elle calcule comme étant l'heure 4 am ou 4 pm.

Je ne sais pas comment bypasser le format spécialisé, j'ai même essayé de l'enlever d'excel.

Si quelqu'un pouvait me donner une piste de solution, ce serait gentil.

MErci
extraction alphanum forum.xlsx
(22.5 Kio) Téléchargé 13 fois
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'171
Appréciations reçues : 448
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 8 décembre 2016, 15:04

Bonjour,
=SIERREUR(CNUM(STXT(A2;MIN(SI(ESTNUM(CHERCHE({0.1.2.3.4.5.6.7.8.9};A2));CHERCHE({0.1.2.3.4.5.6.7.8.9};A2);""));SOMMEPROD(--(ESTNUM(CNUM(STXT(A2;LIGNE($1:$100);1)))))));"")
Ça l'allonge un peu, mais on peut peut-être l'améliorer.
Avatar du membre
spage
Membre habitué
Membre habitué
Messages : 94
Appréciations reçues : 2
Inscrit le : 3 février 2014
Version d'Excel : 2010

Message par spage » 12 décembre 2016, 15:16

Wow!

C*est magnifique.

Un gros merci, Je vais pouvoir la mettre en application des' aujourd<hui.

Je la d/cortiquerai plus tard.

Si j<ai des questions sur la composition.... surtout avec le sommeprod je reviendrai


Encore merci.

spage
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message