Compter le nombre de cellules sans compter les doublons

Y compris Power BI, Power Query et toute autre question en lien avec Excel
R
RafMax
Jeune membre
Jeune membre
Messages : 42
Inscrit le : 4 juillet 2013
Version d'Excel : 2010

Message par RafMax » 28 novembre 2016, 07:12

Bonjour,

Je cherche une formule qui permet de compter le nombre de cellules (texte ou numérique) mais sans compter 2 fois les doublons ou 3 fois les triplés, ...

Une formule "classique", non matricielle si possible.

Par avance : un grand merci. Cela me semblait simple au départ mais plusieurs heures passées en vain ...

A l'aide !

PS : un fichier qui indique le résultat attendu.
Compta unique cellules avec doublons.xlsx
(9.83 Kio) Téléchargé 111 fois
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'171
Appréciations reçues : 446
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 28 novembre 2016, 07:20

Bonjour,

La formule classique en la matière !
=SOMMEPROD(1/NB.SI(A2:A20;A2:A20))
Cordialement.
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'353
Appréciations reçues : 396
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 28 novembre 2016, 07:21

Bonjour,
=SOMME(SI(A1:A100<>"";1/NB.SI(A1:A100;A1:A100)))-1
formule matricielle à valider avec Shift+Ctrl+Entrée
eric
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
R
RafMax
Jeune membre
Jeune membre
Messages : 42
Inscrit le : 4 juillet 2013
Version d'Excel : 2010

Message par RafMax » 28 novembre 2016, 07:29

MFerrand a écrit :Bonjour,

La formule classique en la matière !
=SOMMEPROD(1/NB.SI(A2:A20;A2:A20))
Cordialement.
Merci MFerrand pour le temps consacré à la recherche de cette formule. Elle fonctionne très bien sur mon petit tableau. En revanche sur mon grand tableau (35000 lignes) le résultat est de 0 donc je pense que cette formule a une limite de lignes.

Un plan B ?
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'171
Appréciations reçues : 446
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 28 novembre 2016, 08:16

Formule "classique"... donc recherche nulle (elle fait partie du bagage standard des pratiquants d'Excel). :D

Elle ne supporte pas le cellule vide dans la plage de comptage, et renvoie alors l'erreur de division par 0 (logique !)
On peut alors y substituer :
=SOMME(SI(A2:A20<>"";1/NB.SI(A2:A20;A2:A20)))
Mais ici, validation matricielle...

Le renvoi 0 suppose une fausse manoeuvre quelque part...

Cordialement.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message