Extraction de données Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
f
fredolilo
Membre habitué
Membre habitué
Messages : 58
Inscrit le : 13 octobre 2016
Version d'Excel : 2007

Message par fredolilo » 13 octobre 2016, 18:20

Bonjour ,
si vous pouvez m aider, j ai un tableau avec 2 colonnes, colonne A des équipements et colonne B une date, je souhaiterais extraire dans un nouvel onglet la liste des équipements pour une date précise.

Merci pour votre aide.
aide.xlsx
(11.87 Kio) Téléchargé 7 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 13 octobre 2016, 18:32

Bonjour le forum,

C2 :
=SI(LIGNE()-1>NB.SI(calendrier!B:B;$A$1);"";INDEX(calendrier!A:A;PETITE.VALEUR(SI(calendrier!B:B=$A$1;LIGNE(A:A);"");LIGNE()-1)))
Formule matricielle à valider avec CTRL MAJ ENTREE
f
fredolilo
Membre habitué
Membre habitué
Messages : 58
Inscrit le : 13 octobre 2016
Version d'Excel : 2007

Message par fredolilo » 13 octobre 2016, 19:00

Merci pour ta reponse, je pense que je suis mal exprimé, j aimerais extraire dans un second onglet "à effectuer dans le tableau joint" la liste des des résultats de la colonne A pour une date précisé en A1 dans l'onglet à effectuer.
Si je ne trouve pas de solution je ferai un simple TCD.

Merci quand même.
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'789
Appréciations reçues : 262
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 13 octobre 2016, 19:44

bonjour
un essai avec deux procédés
fredolilo.xlsx
(12.95 Kio) Téléchargé 14 fois
les plages sont nommées en dynamique
cordialement
c'est en cherchant qu'on trouve
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 13 octobre 2016, 19:51

C3 :
=SI(calendrier!B2<=$A$1;DECALER(calendrier!B2;0;-1);"")
Liste.png
Liste.png (8.24 Kio) Vu 128 fois
f
fredolilo
Membre habitué
Membre habitué
Messages : 58
Inscrit le : 13 octobre 2016
Version d'Excel : 2007

Message par fredolilo » 14 octobre 2016, 09:13

Merci à tous, tout ce que vous m avez proposé correspond à mon besoin, maintenant je vais essayer de comprendre pour progresser.
A la prochaine et encore merci. :)
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Extraction données
    par Florent38170 » 1 avril 2020, 14:53 » dans Excel - VBA
    13 Réponses
    112 Vues
    Dernier message par Florent38170
    2 avril 2020, 08:49
  • Extraction de données
    par Vitya » 22 mai 2016, 00:15 » dans Excel - VBA
    4 Réponses
    141 Vues
    Dernier message par Vitya
    25 mai 2016, 09:56
  • extraction de données
    par jad73 » 12 avril 2015, 10:29 » dans Excel - VBA
    2 Réponses
    132 Vues
    Dernier message par jad73
    12 avril 2015, 12:01
  • Extraction donnees
    par miha » 4 février 2018, 22:33 » dans Excel - VBA
    1 Réponses
    111 Vues
    Dernier message par i20100
    5 février 2018, 06:23
  • Extraction de données
    par grbzh » 15 novembre 2016, 18:11 » dans Excel - VBA
    5 Réponses
    164 Vues
    Dernier message par grbzh
    16 novembre 2016, 09:01
  • Extraction de données
    par Cote-co » 28 juin 2018, 09:52 » dans Excel - VBA
    3 Réponses
    182 Vues
    Dernier message par tulipe_4
    30 juillet 2018, 16:16