Extraction de données Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
f
fredolilo
Membre habitué
Membre habitué
Messages : 55
Inscrit le : 13 octobre 2016
Version d'Excel : 2007

Message par fredolilo » 13 octobre 2016, 18:20

Bonjour ,
si vous pouvez m aider, j ai un tableau avec 2 colonnes, colonne A des équipements et colonne B une date, je souhaiterais extraire dans un nouvel onglet la liste des équipements pour une date précise.

Merci pour votre aide.
aide.xlsx
(11.87 Kio) Téléchargé 7 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'412
Appréciations reçues : 244
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 13 octobre 2016, 18:32

Bonjour le forum,

C2 :
=SI(LIGNE()-1>NB.SI(calendrier!B:B;$A$1);"";INDEX(calendrier!A:A;PETITE.VALEUR(SI(calendrier!B:B=$A$1;LIGNE(A:A);"");LIGNE()-1)))
Formule matricielle à valider avec CTRL MAJ ENTREE
f
fredolilo
Membre habitué
Membre habitué
Messages : 55
Inscrit le : 13 octobre 2016
Version d'Excel : 2007

Message par fredolilo » 13 octobre 2016, 19:00

Merci pour ta reponse, je pense que je suis mal exprimé, j aimerais extraire dans un second onglet "à effectuer dans le tableau joint" la liste des des résultats de la colonne A pour une date précisé en A1 dans l'onglet à effectuer.
Si je ne trouve pas de solution je ferai un simple TCD.

Merci quand même.
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'397
Appréciations reçues : 207
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 13 octobre 2016, 19:44

bonjour
un essai avec deux procédés
fredolilo.xlsx
(12.95 Kio) Téléchargé 14 fois
les plages sont nommées en dynamique
cordialement
c'est en cherchant qu'on trouve
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'412
Appréciations reçues : 244
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 13 octobre 2016, 19:51

C3 :
=SI(calendrier!B2<=$A$1;DECALER(calendrier!B2;0;-1);"")
Liste.png
Liste.png (8.24 Kio) Vu 116 fois
f
fredolilo
Membre habitué
Membre habitué
Messages : 55
Inscrit le : 13 octobre 2016
Version d'Excel : 2007

Message par fredolilo » 14 octobre 2016, 09:13

Merci à tous, tout ce que vous m avez proposé correspond à mon besoin, maintenant je vais essayer de comprendre pour progresser.
A la prochaine et encore merci. :)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • extraction de données
    par kholkhol » 20 juillet 2014, 20:21 » dans Excel - VBA
    8 Réponses
    254 Vues
    Dernier message par Banzai64
    21 juillet 2014, 11:46
  • Extraction de données
    par Vitya » 22 mai 2016, 00:15 » dans Excel - VBA
    4 Réponses
    130 Vues
    Dernier message par Vitya
    25 mai 2016, 09:56
  • extraction données
    par freddy93 » 3 février 2014, 16:47 » dans Excel - VBA
    1 Réponses
    130 Vues
    Dernier message par gmb
    4 février 2014, 13:14
  • Extraction de données
    par Beberttlse31 » 17 octobre 2018, 22:49 » dans Excel - VBA
    8 Réponses
    111 Vues
    Dernier message par curulis57
    19 octobre 2018, 23:24
  • Extraction de données
    par KingThanos » 10 avril 2018, 09:20 » dans Excel - VBA
    8 Réponses
    180 Vues
    Dernier message par jmd
    10 avril 2018, 17:54
  • Extraction de données
    par Delgusto » 28 février 2019, 17:00 » dans Excel - VBA
    25 Réponses
    383 Vues
    Dernier message par Delgusto
    3 mars 2019, 15:57