Gestion des doublons

Bonjour à tous,

Est-ce qu'il est possible d'avoir une colonne A avec des noms, une colonne B avec soit oui ou non et une colonne C qui indiquerait un numéro ?

Dupont OUI réalisation 1

Dupont NON ""

Dupont OUI réalisation 2

Durant OUI réalisation 1

Je voudrais empêcher par exemple que DUPONT ait un doublon réalisation 1.

Merci d'avance pour votre aide.

bonjour,

ce n'est pas très clair tout ça, pourrais-tu joindre un fichier exemple avec le résultat souhaité ?

parceque

kenny972 a écrit :

Je voudrais empêcher par exemple que DUPONT ait un doublon réalisation 1.

ça ne nous dit pas ce qu'on fait si jamais ça arrive, on met la cellule en rouge ? on supprime la ligne ? On pleure et on demande aux comptable de resaisir les données ?

Effectivement ce n'est pas très clair,

Je voudrais une incrémentation automatique comme dans le fichier joint.

Une fois que les 2 conditions sont réalisée, à savoir un nom et un "oui" alors je fais dernière réalisation + 1.

Merci.

9classeur1.xlsx (12.72 Ko)

Bonjour,

=SI(B2="oui";"réalisation "&NB.SI.ENS($A$2:$A2;A2;$B$2:$B2;"oui");"")

eric

Bonjour,

Une petite simplication de la formule d'Eric... :

  • mettre en colonne C format de cellule personnalisé : "réalisation "0
  • formule en C2 (à tirer sur la colonne) :
=SI(B2="oui";NB.SI($A$1:A2;A2);"")

Cordialement.

Merci à vous 2, c'est MaGniFIQUE exactement ce que je voulais.

Par contre dernière petite question, si dans ma colonne B je veux une autre condition par exemple oui/non/ en cours et que le en cours renvoie la dernière valeur de la réalisation X. Je m'explique :

Dupont oui réalisation 1

Dupont oui réalisation 2

Dupont en cours réalisation 2

Est-ce possible ? j'ai essayé avec SI(OU() mais çà ne fonctionne pas

Re,

Tu peux faire une chaine de si, dans la condition Sinon du premier ( donc après le deuxième " ; ") tu met un autre Si

Si(blabla;Faire ça ;Si(blabla2;Faire ça;Faire ça))

réitérable a l'infini

En rectifiant ma première formule ( ) :

=SI(B2="oui";NB.SI.ENS($A$1:A2;A2;$B$1:B2;"oui");SI(B2="en cours";NB.SI.ENS($A$1:A1;A2;$B$1:B1;"oui");""))

Cordialement.

NB- Si "en cours" apparaît avant qu'il y ait une réalisation 1, cela affichera réalisation 0.

et en modifiant la mienne :

=SI(B2<>"non";"réalisation "&NB.SI.ENS($A$2:$A2;A2;$B$2:$B2;"oui");"")

qui devient :

=SI(B2<>"non";NB.SI.ENS($A$2:$A2;A2;$B$2:$B2;"oui");"")

si tu utilises le format proposé par MFerrand

eric

Judicieux Eric !

n'exagerons rien

Rien d'exagéré ! C'est bien ce qu'on appelle une optimisation... !

[NB- Je suis par ailleurs avec attention tes propos sur la "latence" affectant un gros classeur... J'ai justement un léger phénomène de latence de ce type (plus réduit) où le poids du classeur n'est a-priori pas en cause (575 ko), qui ne me pose pas problème vu son utilisation (listes d'albums musicaux numérisés), mais je m'étais dit qu'il serait bon d'élucider les raisons de la chose, et je me livrerai à quelques expériences à partir des éléments que tu fournis...]

Messieurs, en tout cas un grand merci.

Rechercher des sujets similaires à "gestion doublons"