Gestion des doublons

Y compris Power BI, Power Query et toute autre question en lien avec Excel
k
kenny972
Jeune membre
Jeune membre
Messages : 45
Inscrit le : 28 juillet 2016
Version d'Excel : 2013

Message par kenny972 » 22 septembre 2016, 11:39

Bonjour à tous,

Est-ce qu'il est possible d'avoir une colonne A avec des noms, une colonne B avec soit oui ou non et une colonne C qui indiquerait un numéro ?

Dupont OUI réalisation 1
Dupont NON ""
Dupont OUI réalisation 2
Durant OUI réalisation 1

Je voudrais empêcher par exemple que DUPONT ait un doublon réalisation 1.

Merci d'avance pour votre aide.
Avatar du membre
Watewmark
Membre fidèle
Membre fidèle
Messages : 370
Appréciations reçues : 3
Inscrit le : 8 septembre 2016
Version d'Excel : 2010 FR

Message par Watewmark » 22 septembre 2016, 11:54

bonjour,

ce n'est pas très clair tout ça, pourrais-tu joindre un fichier exemple avec le résultat souhaité ?
parceque
kenny972 a écrit :Je voudrais empêcher par exemple que DUPONT ait un doublon réalisation 1.
ça ne nous dit pas ce qu'on fait si jamais ça arrive, on met la cellule en rouge ? on supprime la ligne ? On pleure et on demande aux comptable de resaisir les données ? :lol:
Avatar sous copyright, n'hesitez pas a aller voir le travail de Diane Özdamar sur deviant-art
k
kenny972
Jeune membre
Jeune membre
Messages : 45
Inscrit le : 28 juillet 2016
Version d'Excel : 2013

Message par kenny972 » 22 septembre 2016, 12:07

Effectivement ce n'est pas très clair, :?

Je voudrais une incrémentation automatique comme dans le fichier joint.
Une fois que les 2 conditions sont réalisée, à savoir un nom et un "oui" alors je fais dernière réalisation + 1.

Merci.
Classeur1.xlsx
(12.72 Kio) Téléchargé 9 fois
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'419
Appréciations reçues : 405
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 22 septembre 2016, 12:13

Bonjour,
=SI(B2="oui";"réalisation "&NB.SI.ENS($A$2:$A2;A2;$B$2:$B2;"oui");"")
eric
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'171
Appréciations reçues : 447
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 22 septembre 2016, 12:43

Bonjour,

Une petite simplication de la formule d'Eric... :
-mettre en colonne C format de cellule personnalisé : "réalisation "0
-formule en C2 (à tirer sur la colonne) :
=SI(B2="oui";NB.SI($A$1:A2;A2);"")
Cordialement.
kenny972_Classeur1.xlsx
(12.25 Kio) Téléchargé 10 fois
k
kenny972
Jeune membre
Jeune membre
Messages : 45
Inscrit le : 28 juillet 2016
Version d'Excel : 2013

Message par kenny972 » 22 septembre 2016, 12:57

Merci à vous 2, c'est MaGniFIQUE exactement ce que je voulais.

Par contre dernière petite question, si dans ma colonne B je veux une autre condition par exemple oui/non/ en cours et que le en cours renvoie la dernière valeur de la réalisation X. Je m'explique :

Dupont oui réalisation 1
Dupont oui réalisation 2
Dupont en cours réalisation 2

Est-ce possible ? j'ai essayé avec SI(OU() mais çà ne fonctionne pas :(
Avatar du membre
Watewmark
Membre fidèle
Membre fidèle
Messages : 370
Appréciations reçues : 3
Inscrit le : 8 septembre 2016
Version d'Excel : 2010 FR

Message par Watewmark » 22 septembre 2016, 13:10

Re,

Tu peux faire une chaine de si, dans la condition Sinon du premier ( donc après le deuxième " ; ") tu met un autre Si

Si(blabla;Faire ça ;Si(blabla2;Faire ça;Faire ça))

réitérable a l'infini :mrgreen:
Avatar sous copyright, n'hesitez pas a aller voir le travail de Diane Özdamar sur deviant-art
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'171
Appréciations reçues : 447
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 22 septembre 2016, 13:18

En rectifiant ma première formule ( :( ) :
=SI(B2="oui";NB.SI.ENS($A$1:A2;A2;$B$1:B2;"oui");SI(B2="en cours";NB.SI.ENS($A$1:A1;A2;$B$1:B1;"oui");""))
Cordialement.

NB- Si "en cours" apparaît avant qu'il y ait une réalisation 1, cela affichera réalisation 0.
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'419
Appréciations reçues : 405
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 22 septembre 2016, 15:38

et en modifiant la mienne :
=SI(B2<>"non";"réalisation "&NB.SI.ENS($A$2:$A2;A2;$B$2:$B2;"oui");"")
qui devient :
=SI(B2<>"non";NB.SI.ENS($A$2:$A2;A2;$B$2:$B2;"oui");"")
si tu utilises le format proposé par MFerrand
eric
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'171
Appréciations reçues : 447
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 22 septembre 2016, 15:52

Judicieux Eric ! |k)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Gestion de doublons
    par TomRL » 21 juin 2018, 11:51 » dans Excel - VBA
    4 Réponses
    167 Vues
    Dernier message par TomRL
    25 juin 2018, 18:03
  • gestion des doublons
    par Letikeur » 9 mai 2016, 11:21 » dans Excel - VBA
    2 Réponses
    161 Vues
    Dernier message par Letikeur
    9 mai 2016, 12:01
  • Gestion des doublons
    par jpsept » 16 septembre 2014, 17:41 » dans Excel - VBA
    1 Réponses
    262 Vues
    Dernier message par Banzai64
    16 septembre 2014, 18:11
  • Gestion des doublons
    par Chouspy » 15 avril 2015, 10:00 » dans Excel - VBA
    5 Réponses
    267 Vues
    Dernier message par Klin89
    15 avril 2015, 18:56
  • Gestion des doublons
    par pilou21 » 1 septembre 2019, 18:24 » dans Excel - VBA
    5 Réponses
    86 Vues
    Dernier message par pilou21
    2 septembre 2019, 21:36
  • Gestion des doublons VBA
    par Prypry » 13 octobre 2015, 12:16 » dans Excel - VBA
    6 Réponses
    294 Vues
    Dernier message par Prypry
    13 octobre 2015, 17:11