Recherche avec plusieurs résultats et plusieurs critères

Y compris Power BI, Power Query et toute autre question en lien avec Excel
M
MarcHenry
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 25 août 2016
Version d'Excel : 2010 FR

Message par MarcHenry » 25 août 2016, 01:43

Salut à tous.
Je bute sur un petit problème pour effectuer une recherche avec plusieurs résultats et plusieurs critères dans ma base de données.

Je suis parapentiste et je tiens à jour un carnet de vols (que je complète dans l'onglet CDV avec le nom du site, le temps de vol et la date). Je vole sur plusieurs site et j'aimerais pouvoir définir le nombre de vols et le temps de vol par site et par année (dans l'onglet Liste des sites).

La fonction rechercheV ne m'avance pas trop car elle ne sort qu'un seul résultat à la fois.

Merci pour votre aide. En PJ le fichier.
fichier de comptage test.xlsx
(23.87 Kio) Téléchargé 56 fois
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'786
Appréciations reçues : 38
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 25 août 2016, 01:51

Bonsoir,
:bv:
en C2 :
=SOMME.SI.ENS(CDV!$B:$B;CDV!$A:$A;$A2;CDV!$E:$E;2010+COLONNES($C:C))
@ tirer vers le bas et vers la droite

Voir PJ
MarcHenry.xlsx
(25.6 Kio) Téléchargé 93 fois

@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
M
MarcHenry
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 25 août 2016
Version d'Excel : 2010 FR

Message par MarcHenry » 25 août 2016, 12:26

Salut

Merci, excellente solution !

Je te remercie pour ta réactivité en pleine nuit :D
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message