Rechercher valeur dans liste et remplir cellule en fonction

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
n
nzoprod
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 13 mai 2014
Version d'Excel : 2007 FR

Message par nzoprod » 5 août 2016, 15:45

Bonjour à tous !!!

Je me demande si il était possible de trouver une solution à mon problème (si pas de solution c'est que y a pas de pb ;))

Ce que je veux faire:
J'ai un tableau excel contenant 2 listes, une liste avec des items et une liste avec des items plus des noms et réfs constructeurs...
J'aimerai pouvoir, rechercher dans la 1ere liste si l'item est présent dans la 2eme liste, et si oui que cela me renseigne l'info (nom par ex) de la cellule correspond à l'item (situéé sur la meme ligne)...

En esperant avoir été clair, je joins un exemple (en vert, les infos que j'aimerai récup !)

Pour info, je débute excel mais aime bien me creuser, j'ai essayer qques trucs (rechercheV, SI (nb.si (cellule; plage cellule) etc etc
mais la je bloque un peu !!

Merci à ceux qui pourront / voudront m'aider et/ou me donner des pistes !
Laurent
exemple_SOS.xls
exemple ;)
(21 Kio) Téléchargé 45 fois
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'171
Appréciations reçues : 448
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 5 août 2016, 16:02

Bonjour,

1) Nommer Item la colonne ITEM de liste2 (soit F6:F16)
2) Formule en C6 :
=SIERREUR(DECALER(Item;EQUIV($B6;Item;0)-1;COLONNE(A:A);1);"")
3) Etendre cette formule (recopier) sur l'ensemble de la plage C6:D31

Les noms et réf des constructeurs s'afficheront s'ils figurent dans Liste2.

Cordialement.
n
nzoprod
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 13 mai 2014
Version d'Excel : 2007 FR

Message par nzoprod » 5 août 2016, 16:20

merci 1erement pour votre retour rapide !!
je viens de tester mais j'ai du me tromper car ca ne marche pas
qu'entendez vous par nommer item la colonne item?

RE merci encore !!!!
CDLT,
Laurent

Re M. Ferrand !!

C'est bon désolé j'ai renommé la plage !!!

UN ENORME MERCI

AU TOP !!!!

BON WEEK et LONGUE VIE AU FORUM
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'171
Appréciations reçues : 448
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 5 août 2016, 16:41

Bonne continuation !
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message