Mettre une liste dans la condition de Somme.SI.ENS Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
C
Chicoo
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 28 juillet 2016
Version d'Excel : 2010 FR

Message par Chicoo » 28 juillet 2016, 12:34

Bonjour,

Pour un calcul d'indicateurs, j'utilise la fonction Somme.SI.ENS. Je ne peux pas vous transférer le dossier pour cause de confidentialité. Ma formule ressemble à :

=SOMME.SI.ENS($Q:$Q;$H:$H;"*"&"Arbre"&"*";$P:$P;Résumé!$C$6)+SOMME.SI.ENS($Q:$Q;$H:$H;"*"&"Maison"&"*";$P:$P;
Résumé!$C$6)+SOMME.SI.ENS($Q:$Q;$H:$H;"*"&"Bateau"&"*";$P:$P;Résumé!$C$6)

Elle est très lourde et pas facile à modifier. J'aimerai donc, au lieu de mettre 3 Somme.SI.ENS, en mettre qu'un seul. Le seul critère qui varie étant le premier critère, j'aimerai faire une Liste avec "*"&"Arbre"&"*","*"&"Maison"&"*" et "*"&"Bateau"&"*" et insérer cette liste pour avoir une formule qui ressemble à :

=SOMME.SI.ENS($Q:$Q;$H:$H;Liste;$P:$P;Résumé!$C$6)

Savez vous comment je peux faire ?

Je vous remercie pour votre aide.
Modifié en dernier par Chicoo le 28 juillet 2016, 15:01, modifié 2 fois.
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'798
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 28 juillet 2016, 12:57

Bonjour,
:bv:
on ne demande pas le fichier réel, juste un exemple sans données confidentielles suffira.
:joindre:

@ te relire
"Donnez moi un point d'appui et je soulèverai le monde"
C
Chicoo
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 28 juillet 2016
Version d'Excel : 2010 FR

Message par Chicoo » 28 juillet 2016, 15:14

J'ai fait un petit excel rapide. Le tableau est un peu décousu mais c'est pour qu'il colle à la formule. J'ai mis la formule dans "Total" et à côté j'ai mis la liste que j'aimerai intégrer afin de n'avoir qu'un seul terme au lieu de trois dans ma formule.
Classeur1.xlsx
(12.5 Kio) Téléchargé 27 fois
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'798
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 28 juillet 2016, 15:30

Re,
avec une formule matricielle à valider par la combinaison des 3 touches Ctrl+Shift+Enter
Chicoo.xlsx
(11.05 Kio) Téléchargé 32 fois

@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
Avatar du membre
Elhevan
Membre fidèle
Membre fidèle
Messages : 243
Inscrit le : 1 juillet 2016
Version d'Excel : Home : 2016 EN Work : 2010 FR

Message par Elhevan » 28 juillet 2016, 15:33

Bonjour.

=SOMME(SOMME.SI.ENS($Q:$Q;$H:$H;{"*maison*";"*arbre*";"*bateau*"};$P:$P;Résumé!$C$6))

Bonne journée.

Edit : Coucou R@chid
Mia san mia.

On n'envoie pas des satellites avec des yourtes !
C
Chicoo
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 28 juillet 2016
Version d'Excel : 2010 FR

Message par Chicoo » 28 juillet 2016, 15:44

Merci pour vos réponses.

@Rachid : ça marche bien, mais du coup pas possible de juste entrer une liste dans le Somme.Si.Ens? Parce que j'ai le même problème dans une autre formule avec un Nb.Si.Ens donc ça m'arrangerait si je pouvais juste insérer une liste.

@Elhevan : Ta formule me renvoie : VRAI....
Avatar du membre
Elhevan
Membre fidèle
Membre fidèle
Messages : 243
Inscrit le : 1 juillet 2016
Version d'Excel : Home : 2016 EN Work : 2010 FR

Message par Elhevan » 28 juillet 2016, 15:48

Et pourtant !
Copie de Classeur1.xlsx
(11.02 Kio) Téléchargé 27 fois
Mia san mia.

On n'envoie pas des satellites avec des yourtes !
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'798
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 28 juillet 2016, 15:54

Re,
la formule de l'ami Elhevan est une formule matricielle il faut la valider matriciellement.
ou bien l'adapter comme ça :
=SOMMEPROD(SOMME.SI.ENS($Q:$Q;$H:$H;{"*maison*";"*arbre*";"*bateau*"};$P:$P;Résumé!$C$6))

@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
C
Chicoo
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 28 juillet 2016
Version d'Excel : 2010 FR

Message par Chicoo » 28 juillet 2016, 16:34

Ok je suis un boulet, je sais pas trop ce que j'ai fait, parce même en validant matriciellement ça ne passait pas. Une dernière question :
Si je veux transformer 3 cellules contenant "*maison*", "*arbre*" et "*bateau*" en colonnes en une liste comme celle qui est utilisée dans la formule : {"*maison*";"*arbre*";"*bateau*"} je fais comment? Je fais un Transpose(K19:K21) j'imagine et ensuite?
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'798
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 28 juillet 2016, 17:03

Re,
voir PJ
Chicoo_2.xlsx
(11.17 Kio) Téléchargé 35 fois
@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message