formule SI plusieurs conditions Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
M
MelleBulle
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 24 juin 2015
Version d'Excel : 2007

Message par MelleBulle » 27 mai 2016, 09:32

Bonjour

Je réalise un tableau pour un suivi d'action
Dans la case J11 j'ai une "date butoir de réalisation"
Dans la case P11 j'ai une "date réelle de réalisation"

Mon souhait est le suivant :
inscrire dans la case N11 l'état de mon action, c'est à dire
si P11 est remplie inscrire " action réalisée"
Si P11 non remplie 3 résultats possibles , si la date butoir est supérieure à la "date actuelle - 7jrs" alors ne rien inscrire, si la date butoir est inférieure à la "date d'aujourd'hui -7 jours" alors inscrire "alerte", enfin si la date d'aujourd'hui est supérieure à la date butoir inscrire "délai dépassé",

Est ce que cela est réalisable ??

Merci de votre aide,
Cordialement
E
EmilieR
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 18 mai 2016
Version d'Excel : 2010 FR

Message par EmilieR » 27 mai 2016, 09:52

Si tu saisis cette formule dans la cellule N11, ça devrait être bon.

=SI(estvide(P11);si(J11>(aujourdhui()-7);"";si(J11<=(aujourdhui()-7);"alerte";"délai dépassé"));"action réalisée)

Il y a quelques si imbriqués et on s'y perd plutôt vite donc essaie tous les cas pour voir si ça fonctionne.
M
MelleBulle
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 24 juin 2015
Version d'Excel : 2007

Message par MelleBulle » 27 mai 2016, 10:39

Merci pour ta réponse rapide,
malheureusement la formule ne fonctionne pas... mis à part pour la première condition : si la case date de réalisation est complétée cela indique bien "action réalisée". Je pense également que la condition disant que si la date butoir n'est pas dans moins de 7jours la case reste vide.
Pour les deux autres statuts, cela marque tjr "alerte" même si la date butoir est dépassé...
d
david ge
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 17 mai 2016
Version d'Excel : 2010

Message par david ge » 27 mai 2016, 10:52

Essaye avec ça, mais je suis pas sur de moi

=SI(P11="";N11="Action réalisée";(SI(AUJOURDHUI>N11,"Délai Dépassé";(SI(J11>(AUJOURDHUI-DAY(7));"";(SI(J11=<(AUJOURDHUI-DAY(7));N11="Alerte";"")))))))
E
EmilieR
Jeune membre
Jeune membre
Messages : 17
Inscrit le : 18 mai 2016
Version d'Excel : 2010 FR

Message par EmilieR » 27 mai 2016, 10:57

J'avais noté la formule en mettant les différents cas dans le sens où tu les avait énoncé : grosse erreur de ma part!

En fait, lorsque la date est dépassée, le nombre de jours de la date butoir est inférieur au nombre de jour de la date d'aujourd'hui, donc ça met forcément alerte.
Pour le délai des 7 jours, ce n'était pas bon non plus.
Il faut remettre dans le bon ordre en mettant comme première condition le délai dépassé puis l'alerte. Après, si on n'est pas en délai dépassé ni en alerte, rien n'est inscrit.

=si(estvide(p11);si(aujourdhui()>J11;"délai dépassé";si(J11<=(aujourdhui()+7);"alerte";""));"action réalisée)

Je l'ai testé, ça fonctionne bien :D

A vouloir faire trop vite en excel, on fait n'importe quoi :roll:
M
MelleBulle
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 24 juin 2015
Version d'Excel : 2007

Message par MelleBulle » 27 mai 2016, 11:34

Merci bcp cela fonctionne :):)
Bonne fin de journée
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message